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QuickMeshについて
QuickMeshは工学シミュレーションにおける計算格子ユーティリティ
ソフトウェアです。

有限要素法による構造解析や有限体積法による流体解析等で用いられる
計算格子（メッシュ、グリッド）の作成、可視化、品質の評価、細分
化、格子タイプの変換等を行うことができ、汎用のメッシュジェネレー
タと解析ソルバーの橋渡しとして使われることを想定しています。

QuickMeshでは単純な２次元の構造格子から複雑形状の任意多面体格
子まで幅広く扱うことができ、多様な解析ソルバーの格子ファイルに対
応したインポートとエキスポート機能を備えています。QuickMeshは
マルチプラットホームに対応したデスクトップアプリケーションとし
て、また、計算サーバやスーパコンピュータにおいては、コマンドライ
ンツールとして使用することもできます。研究用途から大規模な設計向
けのシミュレーション解析まで、計算格子が必要となるシーンで役立つ
機能を多く備えており、作業の効率化に貢献できることを願っていま
す。

ユーザーガイドについて
最初の「機能概要」において、QuickMeshが備えている機能一覧と対
応している入出力フォーマットについて概説します。「インストールガ
イド」では、プラットホーム別にQuickMeshのインストール方法とラ
イセンスの設定、起動までの操作手順を説明します。次の「プログラム
の構成」では、QuickMeshのメニュー構成について概説し、基本操作
ガイドにおいて、格子の表示に関する操作方法を説明します。

操作手順、ユーザーガイドの内容などでご不明な点があれば、下記メー
ルアドレスまでお問合せください

support@quickmesh.co.jp1

1 mailto:support@quickmesh.co.jp
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1
機能概要

1.1. 格子の種類

• 構造格子

◦ 2次元, 3次元, シングルブロック, マルチブロック

• 非構造格子 　2次元, 3次元

◦ 要素(セル)形状

▪ 三角形, 四角形

▪ 四面体, 五面体（プリズム, ピラミッド）, 六面体

▪ ハイブリット格子

▪ 任意多面体

◦ 高次精度要素

• ポリゴンメッシュ

◦ 三角形, 四角形, 任意多角形

1.2. ファイルフォーマット

流体解析 Fluent, OpenFOAM, STAR-CD, SU2, CFX, CRUNCH, LS-
FLOW, FaSTAR, CGNS, PLOT3D

構造解析 NASTRAN, ABAQUS, ANSYS, MARC, LS-DYNA,
ADVENTURE

1



表示機能

プリポストシステ
ム

Tecplot, ParaView, Gambit, FieldView, AVS, gmsh,
EnSight, I-deas, Medit

ポリゴンメッシュ STL, 3DS MAX, AutoCAD 3D Face, Wavefront, Stanford
Triangle Format, GNU Triangulated Surface, Object
File Format

1.3. 表示機能

• 表面格子のシェイドイメージ、隠線表示、ワイヤフレーム

• 断面格子形状の表示

• 平面による格子断面の表示

• シュリンク表示

• 一部の拡大

• バウンディングボックスとその寸法の表示

• ノードとセルIDの表示

• ノード座標の表示

• ノード間の距離

• レポート機能

1.4. 格子品質の評価

• 評価基準による色分け

• 評価基準一覧

• ヒストグラム

• クリッピング

1.5. 編集機能

• 境界面パッチの分割とマージ

• 境界面タイプと名前の変更

• セルゾーン（要素プロパティ）の分割とマージ

• セルゾーン（要素プロパティ）タイプと名前の変更

• 共有座標点のマージ
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細分化と最適化

• 境界層セルの生成と修正

• 境界面の引き延ばし

• 選択部分の削除

• 格子のアペンド

• 表面格子データへのフィッティング

1.6. 細分化と最適化

• 等分割による細分化

• 格子形状の最適化

• スムージング

1.7. 格子生成

• 格子構造の生成

• 四面体非構造格子の生成

• 2次元格子の生成

• 簡易形状の自動格子生成

1.8. 対応プラットフォーム

• Windows7、Windows8、Windows10（64bit版のみ）

• Mac OS-X 10.5以降

• Linux
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2
インストールガイド（Windowsでのイ

ンストールから起動まで）

2.1. インストーラ

インストーラの圧縮ファイルとライセンスファイルをデスクトップ等に準備し
ます
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インストーラ

インストーラの圧縮ファイルをマウスの右ボタンでクリックし、メニューから
「すべて展開」を選択します。

展開先のフォルダを指定して[展開ボタン] をクリックします。

展開されたフォルダの中にある"setup.exe"を右クリックし、メニューから「管
理者として実行」を選択します。

PCへの変更を確認するダイアログが表示された場合は「はい」をクリックしま
す。
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インストーラ

インストーラが起動されたら、[Next>] ボタンをクリックします。

インストール先のフォルダを指定し [Next>] ボタンをクリックします。

[Next>] ボタンをクリックします。
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インストーラ

「Create a desktop icon」をクリックし✔を入れ、[Next>] ボタンをクリック
します。

インストーラが起動されたら、[Install] ボタンをクリックしま す。

インストール中の画面が表示されます。
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インストーラ

[Finish] ボタンをクリックし、セットアップが完了します。

“setup.exe” を右クリックし、メニューから「管理者として実行」を選択しま
す。

PCへの変更を確認するダイアログが表示された場合は、[はい] をクリックしま
す。
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インストーラ

「No license file」 のメッセージが表示されます。[Install License] ボタンを
クリックします。

「license-sample.dat」を選択して開きます。

デスクトップのフォルダを開きます。
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アーカイブ

ライセンスのインストールに問題がなければ図のようなダイアログが表示され
るので [OK] をクリックします。

メニューバーからFile→Quitを選択してQuickMeshを終了します。

2.2. アーカイブ

アーカイブファイルとライセンスファイルをデスクトップ等に準備します。
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アーカイブ

アーカイブファイルをマウスの右ボタンでクリックし、メニューから「すべて
展開」を選択します。

展開先のフォルダを指定して [展開] ボタンをクリックします。

“QuickMesh.exe”が実行ファイルになります。
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アーカイブ

“QuickMesh.exe”を右クリックし、「ショートカットの作成」を選択します。

作成されたショートカットをドラッグしてデスクトップに移動させます。

実行ファイル（QuickMesh.exe）か、ショートカットをダブルクリックして起
動させます。
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アーカイブ

図の画面が表示された場合は、[詳細情報] をクリックします。

[実行] をクリックします。

QuickMeshの起動と同時に表示されるダイアログの[Install License] をクリッ
クします。
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アーカイブ

ファイルダイアログにてデスクトップ、あるいはライセンスファイルが保存し
てあるフォルダに移動します。

ライセンスファイルを選択して[開く] ボタンをクリックします。

ライセンスのインストールに問題がなければ図のようなダイアログが表示され
るので [OK] をクリックします。
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アーカイブ

メニューバーからFile→Quitを選択してQuickMeshを終了します。
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3
プログラムの構成

3.1. 画面構成

1. メニューバー

2. アイコンバー

3. グラフィック画面

4. プロパティタブ及びインスペクションタブ

5. ステータス（格子情報）バー

17



メニューバーの構成

3.2. メニューバーの構成

左からから順に

Fileメニュー.
格子ファイルその他の読み書きを行います。

Editメニュー.
格子の変更、修正を行います。

Viewメニュー.
視点の変更、表示方法の選択等を行います。

Feportメニュー.
格子の情報をテーブル形式で表示します。

Convertメニュー.
格子のタイプを変換します。

Meshメニュー.
格子を生成します。

Toolsメニュー.
格子に対する操作その他

Settingsニュー.
格子の操作、表示等に関する変数を設定します。

Windowメニュー.
プログラム画面の大きさ等を設定します。

Helpメニュー.
プログラムについての情報とライセンスを表示します。
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各メニューの詳細

3.3. 各メニューの詳細

3.3.1. Fileメニュー

Open.
メッシュファイルを開きます

Open Recent.
最近開いたメッシュファイルを開き
ます

Append.
メッシュファイルを追加します

Save.
メッシュを読み込んだqmfファイルに
上書き保存します

Save As.
名前をつけてqmfファイルに保存しま
す

Export Mesh.
ファイル形式を指定してメッシュを
保存します

Save Picture.
現在のメッシュ画面をキャプチャし
保存します

Import View Status.
保存した表示状態ファイルを読み込
みます

Export View Status.
現在の表示状態をファイルに保存し
ます

Import Color Status.
保存した色情報ファイルを読み込み
ます

Export Color Status.
現在の色情報をファイルに保存しま
す

Quit.
QuickMeshを終了します

19



Editメニュー

3.3.2. Editメニュー

Undo.
メッシュの変更を元に
戻します

Redo.
メッシュの変更をやり
直します

Subdivide.
メッシュを細分化しま
す

Boundary Layer.
メッシュに境界層を設
けます

Extrude.
メッシュの面を延長し
ます

Surface Name.
境界面の名前を変更し
ます

Surface Type.
境界面の種類を変更し
ます

Block Type.
ブロックの種類を変更
します

SplitSurface.
境界面を複数の境界面
に分割します

Split Cell Zone.
セルゾーンをブロック
ごとに分割します

Fuse Surfaces.
重複面などを統合しま
す

Scale.
メッシュを指定方向に
拡大します

Move.
メッシュを指定した方
向に移動、回転、反転
します

Copy.
メッシュのコピーを指
定した位置に追加しま
す

Delete Visible.
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Editメニュー

Smooth.
メッシュを平滑化しま
す

Projection.
別のメッシュを参照し
投影します

Surface ID.
境界面IDを変更します

Unite Surfaces.
境界面を結合します

Unite Cell Zones.
セルゾーンを結合しま
す

Merge Nodes.
近接節点などを統合し
ます

メッシュの表示されて
いる部分を消去します

Delete Invisible.
メッシュの表示されて
いない部分を消去しま
す
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Viewメニュー

3.3.3. Viewメニュー

Fit.
表示状態を画面に合わ
せます

Zoom.
指定した領域に表示を
拡大します

Magnify.
メッシュの一部を拡大
表示します

View Direction.
視線を軸に合わせます

Create View.

Zoom Out.
表示を縮小します

In plane Rotation.
画面に垂直な軸で表示
を回転します

Light.
光源を切り替えます

Transparency.
メッシュの半透明表示
を切り替えます

Perspective.

Highlight Surface.
マウスポインタ下の境
界面をハイライトしま
す

Cell Index.
セルのインデックスを
表示します

Node Index.
節点のインデックスを
表示します

Node Coordinate.
節点の座標を表示しま
す
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Viewメニュー

視点を保存します

Select View.
保存した視点を再現し
ます

Add/Manage View.
視点を保存、編集しま
す

Zoom In.
表示を拡大します

透視投影と平行投影を
切り替えます

Coordinate Axis.
座標軸の表示を切り替
えます

Bounding Box.
Bounding Boxの表示を
切り替えます

Rotation Center.
視点の回転中心の表示
を切り替えます

Node to Node Distance.
節点間の距離を表示し
ます

Duplicate Nodes.
近接節点をハイライト
します

Duplicate Faces.
重複面をハイライトし
ます

Reset View.
視点を読み込んだ状態
に戻します
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Reportメニュー

3.3.4. Reportメニュー

Global Region.
メッシュ領域の情報

Boundary Region.
境界面領域の情報

Boundary surface.
境界面各量の情報

Volume Region.
セルゾーン領域の情報

Volume Cell.
セルゾーン各量の情報

Block Region.
ブロック領域の情報

Block Dimension.
ブロックの構造についての情報

Skewness.
メッシュの歪度についての情報

Aspect Ratio.
各セルの縦横比についての情報

Volume Ratio.
各セルの体積比についての情報

Jacobian.
２次要素セルのヤコビアンについて
の情報
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Convertメニュー

3.3.5. Convertメニュー

3D to 2D.
3次元メッシュを投影し2次元メッ
シュにします

2D to 3D.
2次元メッシュを3次元メッシュにし
ます

Convert to Tetrahedron.
セルを四面体に切り分けます

Convert to Hexahedron.
セルを六面体に切り分けます

Convert to Triangular Surface.
メッシュを三角形面のみにします

Convert to Triangles.
2次元メッシュを三角形に切り分けま
す

Convert to Quadrilateral.
メッシュを四角形面のみにします

2nd to 1st Order.
2次要素の節点を取り去ります

1st to 2nd Order.
2次要素の節点を追加します
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Meshメニュー

3.3.6. Meshメニュー

Tetrahedron.
表面のみのメッシュからボリューム
メッシュを生成します

Brickmesh.
直方体メッシュを生成します

Structured.
非構造メッシュを構造メッシュに再
分割します

Single Block.
直方体メッシュを生成します

Chamber.
2次元の燃焼室の構造格子を生成しま
す

2D Mesh.
2次元のメッシュを生成します
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Toolsメニュー

3.3.7. Toolsメニュー

Set Structured Index.
構造メッシュのインデックスを割り
振ります

Set Structured Boundary.
2次元メッシュに対して構造格子の境
界を探し設定します

Set High-Order Elements.
分割したセルを高次要素にします

Unset High-Order Elements.
高次要素付きのセルを分割されたセ
ルにします

Correct Face Normal.
メッシュの面を延長します

Unite All Cell Zones.
メッシュを平滑化します

Set Default Surface Name.
境界面に既定の名称をつけます

Mesh Morphing.
メッシュを弾力的に変形させます

Extrude Surface Zones.
境界面の名前を変更します

Slit Surface.
表面メッシュを指定した断面で切り
分けます

2D→3D.
2次元メッシュを3次元メッシュとみ
なします

Clear Undo History.
変更履歴を消去します

Save Pictures.
指定したフォルダ内のメッシュの画
像を保存します

Load Files.
指定したフォルダ内のメッシュを順
に読み込みます

Playback History.
重複面などを統合します

Scale.
メッシュを指定方向に拡大します

Move.
メッシュを指定した方向に移動、回
転、反転します
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Settingsメニュー

3.3.8. Settingsメニュー

Feature Angle.
Feature 線を決める角度を設定します

Light position.
光の入射方向を設定します

Perspective Level.
透視投影表示の視野角を設定します

Point size.
節点を表示するときの大きさを設定
します

Magnify.
View機能のMagnify表示を設定しま
す

Decimal Places.
数値表示の有効桁を設定します

Bounding Box.
Bounding Boxの表示を設定します

Rotation Center.
視点の回転中心を設定します

Color Mode.
境界面に割り振る色モードの設定を
します

Background Color.
背景色を設定します

Undo Levels.
変更履歴の保持数を設定します

Axis Merge Factor.
座標値が一致するとみなされる閾値
を設定します。
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Windowメニュー

3.3.9. Windowメニュー

Full Screen.
フルスクリーンにします

Resize.
ウィンドウサイズを設定します

Hide Tab.
プロパティ／インスペクションタブを非表示にします
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Helpメニュー

3.3.10. Helpメニュー

About.
このソフトウェアの情報を表示します

Open Source License.
オープンソースライブラリのクレジットを表示します
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アイコンバーの構成

3.4. アイコンバーの構成

Open アイコン.
格子ファイルを読み込
みます

Save アイコン.
QuickMesh形式 のファ
イルに格子データを保
存します

Export アイコン.
選択した形式で格子
ファイルを書き込みま
す

SavePict アイコン.
画像ファイルを保存し
ます

Fit アイコン.
モデルを画面表示に
フィットさせます

Zoom アイコン.
ドラッグして選択した
部分を拡大表示します

XView アイコン.
X座標軸からの視点で表
示されます

YView アイコン.
Y座標軸からの視点で表
示されます

ZView アイコン.

IsoView アイコン.
視点を初期状態に戻し
ます

Vertical アイコン.
モデルを画面の垂直軸
で回転させます

Horizontal アイコン.
モデルを画面の水平軸
で回転させます

Center アイコン.
モデルを画面の中心軸
で回転させます

Rotation ボックス.
回転角度を設定します

Outline アイコン.
境界面の輪郭を表示し
ます

Feature アイコン.
特徴線を表示します

FreeEdge アイコン.
自由縁を表示します

Wire アイコン.
境界面の格子をワイヤ
フレームで表示します

Hidden アイコン.
ワイヤフレームを隠線
消去表示します

Face アイコン.
境界面の格子を塗りつ
ぶし表示します

Solid アイコン.
境界面を塗りつぶし表
示します

Cell アイコン.
内部セルを含めてワイ
ヤフレーム表示します

Node アイコン.
節点を表示します

Inside アイコン.
境界面の表裏の表示を
反転させます

Light アイコン.
照明のオンオフを行い
ます

Trans アイコン.
半透明表示のオンオフ
を行います

Pers アイコン.
パースペクティブ表示
のオンオフを行います
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アイコンバーの構成

Z座標軸からの視点で表
示されます
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4
基本操作ガイド

4.1. 格子ファイルの読み込み

QuickMeshに対応するメッシュファイルの読み込みの操
作例をここでは説明しています。メニューバーから行う
読み書きについてはFileメニューの項目にも参照してくだ
さい。

Openアイコンをクリックします
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格子ファイルの読み込み

あるいは、メインメニューからFile→Open…を選択します
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格子ファイルの保存と書き込み

4.2. 格子ファイルの保存と書き込み

QuickMeshに対応するメッシュファイルの書き込みの操
作例をここでは説明しています。メニューバーから行う
読み書きについてはFileメニューの項目にも参照してくだ
さい。

サンプルの STL ファイルを読み込みます。Openアイコンをクリック、ファイ
ルを選択し、[開く] ボタンをクリックします。

メニューバーからMesh→Tetrahedronを選択します。
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マウス操作

4.3. マウス操作

ここではグラフィック画面内でのマウス操作について説
明しています。表示されたモデルの上またはその近辺で
マウスを操作することで視点を移動、回転、視野の拡大
縮小をすることができます。

移動 以下の操作のいずれかで視点の平行移動ができます。

• 中ドラッグ

• Shit + 左ドラッグ

• 左右同時押しドラッグ

回転 以下の操作で視点の回転移動ができます。

• 左ドラッグ
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マウス操作

拡大縮小 以下の操作のいずれで表示範囲が拡大縮小できます。

• ホイール回転

• 右ドラッグ

表示範囲に拡大 以下の操作で指定した範囲に表示範囲を合わせます。この操作
はアイコンバー及びメニューバーのZoomと同じです。

• Ctrl + 左ドラッグ
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アイコンバー

4.4. アイコンバー

ここでは画面上方に設置してあるアイコンバーについて
説明します。アイコンバーでは主に視点の操作やメッ
シュの表示状態を切り替えます。また一部の機能はメ
ニューバーのViewメニューや右クリックメニューでも同
じ機能が提供されています。

Fit メッシュの全体図がグラフィック画面に収まるように表示範囲を調整しま
す。

Zoom アイコンをクリックしてON にしたあとグラフィック画面内 でドラッグ
して指定した範囲に合わせて拡大します。

Xview 視点をX 軸方向にします。

Yview 視点をy 軸方向にします。
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アイコンバー

Zview 視点をz 軸方向にします。

Isoview 視点を等角投影方向（デフォルトの状 態）にします。

Rotation 回転させる角度を指定します。

Vertical グラフィック画面の縦方向を軸にRotation で指定した角度で視点を回
転させます。
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アイコンバー

Horizontal グラフィック画面の横方向を軸に Rotation で指定した角度で視点
を回 転させます。

Center グラフィック画面の視線方向を軸に Rotation で指定した角度で視点を
回 転させます。

Outline 各Surface Zone ごとに開 いている辺をON 状態で表 示します。
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アイコンバー

Feature ON 状態でFeature 角度が 設定できるようになります。 設定した
Feature 角度よりも 共有面同士の角度が小さい辺 をON 状態で表示します。

FreeEdge メッシュ全体で共有面を持た ず開口している辺をON 状 態で表示し
ます。

Wire 表面のメッシュをワイヤーフレ ームで表示します。

Hidden 表面のメッシュをワイヤーフレー ムで前面にあるもののみ表示し ま
す。
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アイコンバー

Face 表面のメッシュの面と辺を表示 します。（デフォルト状態）

Solid 表面のメッシュの面のみを表 示します。

Cell 表面のメッシュをワイヤーフレー ムで前面にあるもののみ表示し ます。
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アイコンバー

Node セルの頂点をON 状態で表 示します。

Inside 裏面を向いたメッシュをON 状態で表示します。

Light 光源の位置を切り替えます。

Trans ON 状態でメッシュを半透明 にします。

Pers 光源の位置を切り替えます。
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アイコンバー
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プロパティタブの操作

4.5. プロパティタブの操作

ここでは画面右方に設置してあるプロパティタブについ
て説明します。プロパティタブでは境界面やセルがどの
ようにゾーン分けや種別分けされているのかが表示さ
れ、ゾーン名を変更したり、グラフィック画面における
メッシュについてゾーンごとに表示/非表示を切り替えた
りすることができます。
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インスペクション

4.6. インスペクション

inspectionタブでは関心のある事柄についてメッシュを
検査することができます。

検査内容

Cellを選択：

Volume, X Coordinate, Y Coordinate, Z Coordinate, Skewness, Aspect
Ratio, Volume Ratio, Cell Group ID, Cell Type, Random, Random of Origin
Cell, Maximum Edge Length, Minimum Edge Length, Average Edge Length,
Minimum Face Area, Maximum Face Area, Average Face Area, Number of
Vertices, Number of Edges, Number of Faces, Cell Center to Wall Distance,
Cell Center to Boundary Distance, Number of Cells Boundary, Number of Cells
from Wallの中から選ぶことが出来ます。

Surfaceを選択：

Area, X Coordinate, Y Coordinate, Z Coordinate, Face Type, Number of
Vertices, Number of Edges, Random, Skewness, Aspect Ratio, Area Ratio,
Adjacent Cell Volume, Adjacent Cell Aspect Ratio, Average Boundary Cell
Height, Minimum Boundary Cell Height, Maximum Boundary Cell Heightから
選ぶことが出来ます。
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インスペクション

検査の対象をセルからフェイスに切り替えます。

検査の対象について全て同じ価値であるように扱います。

メッシュの断面を検査して表示します。

メッシュをY軸方向に垂直な面で切った部分を検査し表示します。
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インスペクション

メッシュをZ軸方向に垂直な面で切った部分を検査し表示します。

メッシュを指定したベクトルに垂直な面で切った部分を検査し表示します。

検査している平面を平行に移動します。
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インスペクション

Coordinateで向き、Positionで指定した値に対して

それ以上の位置にあるセルを表示。

Coordinateで向き、Positionで指定した値に対してそれ以下の位置にあるセル
を表示。

色に対応する値についての情報の表示/非表示を切り替えます。

色に対応する値についての情報の表示位置を左上/右上/左下/右下に移動しま
す。
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インスペクション

ヒストグラムの表示/非表示を切り替えます。

重ねあって後ろ側にある部分を透過して表示するかどうか切り替えます。

透過率を設定します。 大きくするとメッシュ背後の表面の辺が見えるようにな
ります。
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インスペクション

セルの辺を表示するかどうかを切り替えます。

メッシュの外周に色を付けます。

メッシュの外周の色を設定します。

セルを縮小して表示します。
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インスペクション

表示するセルの縮小率を設定します。

検査する対象を絞り込みます。

Clipで、表示中のデータ値に対して絞り込む条件を昇順か降順か指定します。

Number of Cellsで、絞り込むセルまたはフェイスの個数を指定します。
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Fileメニュー

4.7. Fileメニュー

4.7.1. Open

メッシュファイルを開く
QuickMesh対応のメッシュファイルを開きます。ファイ
ルの拡張子などでファイル形式は判断されますが複数候
補がある場合は続けてファイル形式を選択することにな
るます。この機能はアイコンバーのOpenと同じです。

操作方法

1. [メニューバー]→[File]→[Open]

2. 開くファイルを選択する

3. ファイル形式を特定できない場合は候補から選択する

メニューバーのFile→Open…を選択します。

ファイル選択ダイアログが表示されます。この例ではFluent形式で記述された
メッシュファイルpipe-hybrid-01.mshを選択します。
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Open

拡張子 ”.msh” を用いたファイル形式はQuickMeshでは複数あったためフォー
マットの候補を並べたダイアログが表示されました。

選択したメッシュファイルが読み込まれ、表示されました。
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Open Recent

4.7.2. Open Recent

最近読み込んだメッシュファイルを開く
最近読み込んだメッシュファイルを開きます。
QuickMeshに最近読み込まれたファイル10件がサブメ
ニューに表示されます。

操作方法

1. [メニューバー]→[File]→[Open Recent]

2. サブメニューから読み込みたいファイルを選択する

3. ファイル形式を特定できない場合は候補から選択する

メニューバーのFile→Open Recentにマウスカーソルを合わせると最近
QuickMeshに読み込まれた10個までのファイルが表示されます。 よって最近
使用したファイルの場所を探す作業を省略できます。 この例ではpipe-
hybrid-01.mshを再び読み込みます。

他の読み込み作業と同様にファイル形式を確定させるダイアログが表示される
ので、この例ではpipe-hybrid-01.mshの形式に合わせたFluent Mesh/Case
Fileを選択します。
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Open Recent

選択したメッシュファイルが再び読み込まれ、表示されました。
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Append

4.7.3. Append

メッシュファイルを追加で開く
QuickMesh対応のメッシュファイルを開き、現在のメッ
シュに追加します。

操作方法

1. [メニューバー]→[File]→[Append]

2. 追加するファイルを選択する

3. ファイル形式を特定できない場合は候補から選択する

例4.1 メッシュにメッシュを追加する

図のようにメッシュが存在する状態からさらにメッシュファイルを読み
込み、追加します。

メニューバーの File→ Append…を選択します。
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Append

ファイル選択ダイアログが表示されます。 この例ではFluent形式で記述された
メッシュファイル pipe-hybrid-01-zm04_mirror.mshを選択します。

他のファイル読み込み機能と同様に曖昧なファイル形式を確定させます。 この
例では Fluent Mesh/Case Fileを選択し、OKボタンを押します。

既存のメッシュと新たに読み込んだメッシュでZone名に重複があった場合の処
理を決定します。 Uniteは同名Zoneを統合し、RenameはZoneのIDに応じた名
前が新たにつけられます。 この例ではRenameを選択します。
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Append

ファイルの追加が終了しました。PropertyのZoneの数が増加しています。

アイコンバーのFitをクリックすることでメッシュの追加によって広がった全体
像を見ることができます。
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Save

4.7.4. Save

QuickMesh形式ファイルを上書き保存する
QuickMesh専用のメッシュファイル(*.qmf)を読み込んだ
場合、現在のメッシュの状態を上書き保存します。qmf
ファイル以外からメッシュを構築していて上書き先の
qmfファイルが存在しない場合は後述のSave Asと同じ動
作となります。この機能はアイコンバーのSaveと同じで
す。

操作方法

1. qmfファイルを読み込む

2. 何らかの変更を加える

3. [メニューバー]→[File]→[Save]

例4.2 qmfファイルに上書き保存する

qmfファイルを読み込みます。読み込み方は基本操作編のファイルの読
み込みまたはFileメニューのOpenを参照してください。 この例では
pipe-hybrid-01.qmfを読み込みます。
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Save

読み込まれたqmfファイルです。

読み込んだqmfファイルのメッシュを編集しました。 この例では、Editメ
ニューのSubdivide機能を使ってメッシュを分割しました。 メッシュを編集し
たことでステータスバーのファイル名（①）に(modified)が追加されました。
また、変更を加えたことでFileメニューやアイコンバー（②）のSaveが有効に
なっています。

メニューバーのFile→ Saveを選択します。

qmfファイルへの上書き保存が終了しました。 ステータスバーのファイル名の
あとの(modified)表示がなくなり（①）、Saveアイコン（②）が無効になって
います。
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Save As

4.7.5. Save As

QuickMesh 形式ファイルに名前を付けて保
存する

現在のメッシュの状態をQuickmesh 形式のファイル
(*.qmf)として保存します。上書き先がない状態でファイ
ルメニューやアイコン バーの Save 機能（qmf に上書き）
を実行しようとすると、この Save As 機能と同じくファ
イル名を指定して保存することにな ります。

操作方法

1. [メニューバー]→[File]→[Save As]

2. 保存先のディレクトリ、ファイル名を決定する

例4.3 qmfファイルに別名保存する

現在のメッシュの状態をqmf ファイル に保存します。 メニューバーの
File→ Save As…を選択します。

ファイルの保存先とファイル名を設 定し、保存ボタンをクリックします。 この
例ではpipe-hybrid-01- subdivided.qmf というファイル名 で保存します。
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Export Mesh

qmf ファイルへの保存が終了しまし た。 ステータスバーのファイル名がさきほ
ど つけたものに変更されています。

4.7.6. Export Mesh

ファイル形式を指定して保存
現在のメッシュの状態をQuickMesh が対応する任意形式
のファイルとして保存します。この機能はアイコンバー
のExport と同じ です。

操作方法

1. [メニューバー]→[File]→[Export Mesh]

2. 保存先のディレクトリ、ファイル名、ファイル形式を決定する

例4.4 任意形式のファイルに保存する

現在のメッシュの状態をqmf 以外の 形式でファイルに保存します。 この
例ではFluent Mesh/Case File 形式で保存します。 メニューバーのFile→
Export Mesh…を選択します。
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Save Picture

ファイルの保存先とファイル名を設定し、保存ボタンをクリックします。 この
例ではFluent Mesh/Case File 形式で保存するので拡張子はmsh にし ます。

拡張子msh に対応した形式は複数あるため、候補の中からFluent Mesh/Case
File 形式を選択してOK ボタンをクリックします。 これでメッシュは保存され
ました。

4.7.7. Save Picture

メッシュの外観を画像に保存する
現在メッシュ画面に表示されているメッシュを表示され
ている通りに画像ファイルに保存します。

操作方法

1. メッシュの表示状態を調整する

2. [メニューバー]→[File]→[Save Picture]

64



Save Picture

例4.5 キャプチャして画像ファイルに保存する

図のようにメッシュ画面に映ったメッシュの様子を画像ファイルとして
キャプチャします。

メニューバーのFile→ Save Picture…を選択します。

ファイルダイアログが開くので保存先のフォルダとファイル名を入力して保存
ボタンをクリックします。
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Import View Status

メッセージダイアログで画像ファイルが保存されたことが示されました。

実際に保存された画像です。視点が回転された状態でキャプチャされていま
す。

4.7.8. Import View Status

視点ファイルを読み込む
QuickMesh はメッシュを表示する視点の回転や拡大縮小
などの状態をqvsファイルに保存することができます。そ
のファイルを読み込むことによってQuickMeshを一回終
了した後でも視点状態を再現することができます。 qvs
ファイルの保存については次節のExport View Status を
参照してください。

操作方法

1. [メニューバー]→[File]→[Import View status]

2. qvsファイルを選択
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Export View Status

例4.6 qvs ファイルから視点設定を読み込む

あらかじめ保存していたqvs ファイルからView を読み込みます。 メ
ニューバーのFile→ Import View Status を選択します。 qvs ファイルの
保存については次節のExport View Status を参照して ください。

保存していたqvs ファイルを選択します。

View が読み込まれて保存したView が再現できるようなりました。 メニュー
バーのView→ Select View で読み込んだView を使用することができま す。

4.7.9. Export View Status

視点ファイルを書き出す
QuickMesh はメッシュを表示する視点の回転や拡大縮小
などの状態を記録したView を全てqvs ファイルに保存す
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Export View Status

ることができます。 qvs ファイルの読み込みについては
前節のImport View Status を参照してください。

操作方法

1. [メニューバー]→[View]→[Create View] 等でView を数個作成する

2. [メニューバー]→[File]→[Export View Status]

3. qvs ファイルの保存先を追加

例4.7 qvs ファイルに視点設定を出力する

図のような視点をqvs ファイルに保存します。

まずは保存用のView を作ります。ここではView は手順1 の視点のぶん一 つの
みを作りますが手順1-3 を繰り返して複数のView を作成しても一つの qvs ファ
イルに保存できます。メニューバーのView→ Create View を選択します。
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Export View Status

QuickMesh 上で表示されるViewの名前を設定します。これはqvsのファイル名
とは別に設定できます。

作成された全てのView をqsv ファイルに保存します。メニューバーのFile→
Export View Statusを選択します。

qvs ファイルの保存先とファイル名を設定します。保存ボタンでqvsファイルは
保存されます。

保存されたqvs ファイルを確認します。QuickMeshを再起動してメニューバー
のView→Select View の状態から作成したView がリセットされていることを確
認します。

69



Import Color Status

qvs ファイルをインポートすると、再びメニューバーのView→Select Viewを
見るとqvs ファイルに保存したview-for-export が選択できるようになってい
ます。 qvs のインポートについては前節Import View Status を参照してくださ
い。

4.7.10. Import Color Status

メッシュの色情報を入力する
各Zone やType を色別にして表示することは、メッシュ
を可視化する際に有効な手段であり、QuickMesh はこの
表示の配色を自動で設定したりユーザーが編集すること
ができますがQuickMesh で取り扱うことができるファイ
ル形式のほとんどは可視化のときの色情報を保存、指定
する領域がありません。 したがって作業を再開したと
き、同じメッシュを読み込んでもQuickMeshが自動で設
定する配色に戻ってしまいますが、あらかじめ出力して
おいた専用の配色用ファイル(*.qvc)を読み込めば、自身
で設定した配色を再現することができます。 qvc ファイ
ルの出力については次節 Export Color Status を参照して
ください。

操作方法

1. [メニューバー]→[File]→[Import Color Status]

2. [メニューバー]→[File]→[Save Picture]
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Import Color Status

例4.8 qvc ファイルから色情報を読み込む

図のメッシュの配色をあらかじめ保存しておいたqvc ファイルを読み込ん
で 変更します。

メニューバーのFile→ Import Color Status を選択します。

保存していたqvc ファイルを選択して、開くボタンをクリックします。
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Export Color Status

メッシュの配色がqvc によるものになりました。

4.7.11. Export Color Status

メッシュの色情報法を出力する。
各Zone やType を色別にして表示することは、メッシュ
を可視化する際に有効な手段であり、QuickMesh はこの
表示の配色を自動で設定したりユーザーが編集すること
ができますがQuickMesh で取り扱うことができるファイ
ル形式のほとんどは可視化のときの色情報を保存、指定
する領域がありません。したがって作業を再開したと
き、同じメッシュを読み込んでもQuickMeshが自動で設
定する配色に戻ってしまいますが、あらかじめ出力して
おいた専用の配色用ファイル(*.qvc)を読み込めば、自身
で設定した配色を再現することができます。 qvc ファイ
ルの出力については次節 Import Color Status を参照して
ください。

操作方法

1. メッシュの配色を編集する

2. [メニューバー]→[File]→[Export Color Status]

3. qvc ファイルの保存先とファイル名を設定して保存ボタンをクリック

例4.9 qvc ファイルへ色情報を出力する

メッシュの配色を設定します。Property タブの設定したいSurfaces/
Cells 及び Name/Type を選択し、Itemsから色を変えたい項目のID横の色
付きボタンをクリックします。
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Export Color Status

色を選択します。

手順1,2 を繰り返して、配色を編集し終えたらメニューバーのFile→Export
Color Status を選択します。

qvc ファイルの保存先とファイル名を設定します。保存ボタンでqvc ファイル
は保存 されます。

73



Export Color Status

保存されたqvc ファイルを確認します。QuickMeshを再起動して同じモデル
ファイルを読み込みました。メッシュの配色は再び自動設定されています。

保存されたqvc ファイルを確認します。QuickMesh を再起動して同じモ デル
ファイルを読み込みました。メッシュの配色は再び自動設定されています。

qvc ファイルをインポートすると、手順4 で保存した配色が再現されまし
た。qvc のインポートについては前節Import Color Status を参照してくださ
い。
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Editメニュー

4.8. Editメニュー

4.8.1. Subdivide

メッシュを細分化する
分割数を指定して辺を等分割したメッシュを作成するほ
かに、メッシュ化する前の形状を推測して補間をした
り、より元の形状に近い表面メッシュデータを参照して
元の曲面に沿った細分化を行います。

操作方法

1. [メニューバー]→[Edit]→[Subdivide]

2. 分割数、補間オプションを設定してExecuteボタンをクリック

Subdivisionウィンドウの各機能.
Subdivideメニュー

スムージングOFF

A 分割数 メッシュの分割数を指定します。

B スムージング 分割でできた新しい表面頂点を動かして スムージングを実行す
るかどうか指定します。

C 実行ボタン 分割を開始します。

D キャンセルボタン ウィンドウを閉じます。

スムージングON
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Subdivide

A スムージング方法選択

・Interpolate 　元の形状から補間　（Bが開く）

・Project to Sample Surface 参考STLにフィッティング（Cが開く）
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Subdivide

・Hybrid 参考STL にない頂点を形状から補間（B,Cが開く）

B 補間オプション 補間の方法を設定します。

C 参考STL ファイル選択 スムージングの参考にする高精細なSTL ファイルを選択します。

Subdivide～補間オプション～
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Subdivide

Subdivide～補間オプション～

• Feature Angle: フィーチャ角度。スムージングを制限する角度を指定しま
す。
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Subdivide

• Smooth Surface Zone Separately: Surface Zone 境界オプション。 Zone を
またいでスムージングしないようにするか指定します。

• Select Surface Zones : Surface Zone別スムージング対象。Surface Zoneを
個別にスムージングするかどうか設定します。 Aが開きます。

• Expert Setting: Zone別設定詳細。 左から 対象Zone 名、フィーチャとする
面の角、フィーチャとする辺の角。 選択したゾーンごとにフィーチャ角度
を設定します。

• Move Interior Nodes: 内部点移動オプション。 メッシュの内部の点も合わ
せて移動するか指定します。

• Expansion Limit Coefficient: 内部点移動影響度。 内部点を動かす際の影響
度を指定します。

• Advanced Options: 詳細設定。 以下のオプションが開きます。

• Correction Method: 移動先導出法。 下記Directionの方向に従ってスムージ
ングの移動先の解を求める計算方法を設定します。

◦ None: 下記Directionの方向を利用せずに移動します。

◦ Quasi-Newton Method: 準ニュートン法で求めます。

◦ binary Search: 二分法で求めます。

• Direction: 移動方向指定。 スムージングで移動させる方向を面法線由来
か、セルの形状由来か 指定します。

例4.10 メッシュを分割する

メニューバーのEdit→ Subdivide…を選択します。
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Subdivide

分割数を入力して実行ボタンを押します。

メッシュが分割されます。

例4.11 分割して補間でスムージングする

メニューバーのEdit→ Subdivide…を選択します。
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Subdivide

分割数を入力してSmooth にチェックを入れます。

Interpolate（デフォルト）を選択して、Feature としてスムージングをかけな
い角度を指定します。 実行ボタンを押します。

Feature 線をまたいでいない面同士を曲面に補間しながら分割されます。

分割後、このようになります。
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Subdivide

例4.12 分割して参考STLにフィッティングする

このメッシュを、下図のようなSTLファイルの表面形状を参考にして分割
します。

メニューバーのEdit→ Subdivide…を選択します。
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Subdivide

分割数を入力してSmoothにチェックを入れます。 Project to Sample Surface
を選択します。

するとCの設定項目が出現するので…をクリックします。

ファイルの入力ダイアログが開かれるので、サンプルとしたいSTLファイルを
選択し開く。

そのファイルのパスが入力されるので、実行します。
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Subdivide

分割されました。
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Layer Subdivide

4.8.2. Layer Subdivide

層状構造のメッシュを分割する
境界層内に現れるような境界面の各三角形面や四角形面
から柱体状のセルが連結しているような層状構造をした
メッシュデータを分割するのに特化した機能です。

操作方法

1. [メニューバー]→[Edit]→[Layer Subdivide]

2. 分割の起点となる境界面の選択

3. 各方向の分割をしてApplyボタンをクリック

例4.13 層状メッシュを分割する

図のような三角柱セルと六面体セルで構成された層状メッシュをそれぞ
れの方向に対して任意の数で分割します。

メニューバーのEdit→ Layer Subdivide…を選択します。
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Layer Subdivide

まずは層状メッシュとして分割の起点となる境界面ゾーンを選択します。

Selectボタンをクリックします。

ここでは層状構造の境界面がne_z_1となっているので、その境界面ゾーンを選
択します。

ゾーン選択ウィンドウのApplyボタンをクリックします。
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Layer Subdivide

ゾーン選択ウィンドウが閉じ、一つ以上のゾーンを選択したことによって
Number of Divisionが操作可能になります。

ここでは層面内の分割数(Surface Direction)を3に、層の深さ方向の分割数
(Layer Direction)を2に設定します。

Applyボタンをクリックします。

層面内で3分割に、層の深さ方向に2分割されました。

欠けた層状メッシュを分割する
元々層状だった大きなメッシュデータから一部切り出し
た小さなメッシュを考えた場合、切り出し方によって
は、切り出した方のメッシュデータは層状構造が歯抜け
て完全でない場合があります。

しかし、そのような歯抜けのある層状メッシュでもLayer
Subdivideはセル同士の辺の接続状況から層状構造を補完
して分割できる場合があります。
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Layer Subdivide

例4.14 欠けた層状メッシュを分割する

図のメッシュデータは層状構造を持ったメッシュの一部を除去し、欠け
させたデータです。

ここではこのデータを層面内のみ2分割します。

前回と同様にメニューバーのEdit→ Layer Subdivide…を選択し、起点となる
ゾーンを選択します。

面内分割数を2、深さ方向の分割数を1にすることで深さ方向への分割を無効に
します。

Applyボタンをクリックします。
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Boundary Layer

層の面内で2分割されました。

層の起点として選んだnew_z_2に直接接続されてないセルも分割されているこ
とがわかります。

4.8.3. Boundary Layer

メッシュに境界層を設ける
指定した境界面付近に複数の薄い境界層を挿入したり削
除したりすることができます。

操作方法

1. [メニューバー]→[Edit]→[Boundary Layer]

2. 境界層を操作する境界面を選択

3. 境界層操作を選択（挿入/分割/削除）

4. 詳細設定をしてApplyボタンをクリック
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Boundary Layer

例4.15 Add/Edit(Push)モード

Surface Zone付近の頂点を内側に押し込みながら指定した数と格子幅増
加を伴う境界層を挿入します。

A: 選択中の対象Surface Zone（全モード共通）

B: Surface Zone 選択ウィンドウを開く( 全ﾓｰﾄﾞ共通）

C:　ﾓｰﾄﾞ切替タブ

• Number of Base Layers: 追加済みの境界層を利用する、追加済み境界
数の数

• Boundary Cell Height :最外境界層の格子幅

• Number Of Layer Cells: 総境界層数

• Number of Uniform Cells: 格子幅一定となる境界層の数内訳

• Growth Factor: 境界層内側の格子幅を倍率で増加させる。増加倍率。

• Layer Height: 境界層内側の格子幅を加算で増加させる。増加加算
値。

• Adjustment limit

◦ Factor: 内部点の移動を境界層総厚の比率で 制限する。移動制限
比。

◦ Length: 内部点の移動を移動距離で制限する。移動制限距離。
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Boundary Layer

例4.16 Add/Edit(Split)モード

追加する境界層の格子幅を指定して境界層を挿入します。

• Cell Size Ratio: 挿入境界層の格子幅をSurface Zone に対するセルの格
子幅の比で指定します。挿入境界層厚／セル厚比。

• Length: 挿入境界層の格子幅を値で指定します。挿入境界層の格子
幅。

• Feature Angle: 追加済み境界層の数

• Divide New Layer: 挿入した境界層を分割するか決定します

◦ Number of Layers: 分割数

◦ Boundary Cell Height: 最外境界層の格子幅

◦ Number of Uniform Cells: 格子幅一定となる境界層の数内訳
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Boundary Layer

例4.17 Divideモード

すでに存在している境界層を分割しなおします。

• Number of Base Layers : 再分割する追加済み境界層の数

• Number of Modified Layers: 追加済み境界数の数

• Divide option

◦ Equally / Unequally : 格子幅を一定にするか増加させるか決定しま
す

◦ Number of Uniform Cells: 格子幅一定となる境界層の数内訳

◦ Boundary Cell Height : 最外境界層の格子幅
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Boundary Layer

例4.18 Deleteモード

すでに存在している境界層を消去します。

• Number : 消去する追加済み境界層の数

• Adjustment Limit

◦ Factor : 内部点の移動を比率で制限する/ 移動制限比

◦ Length : 内部点の移動を移動距離で制限する/ 移動制限距離
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Boundary Layer

例4.19 境界層を編集するSurface Zoneを指定する（全モード共通操作）

メニューバーのEdit→ Boundary Layer…選択します。

Add Boundary Layerウィンドウが開きます。 リスト内を選択して「>」ボタン
で移動させる、またはメッシュ画面で対象ゾーンをダブルクリックして
（A）、Selected Zonesのリストに移動させます。 対象Surface Zoneをすべ
て右側のリストに入れたらApplyボタンをクリックします。 ここではsphere-
surfaceを対象とし、その内側に境界層を挿入しています。

94



Boundary Layer

例4.20 任意のSurface Zoneの内側に指定した数の境界層を挿入する（Add/Edit(Push)モー
ド）

境界層を挿入したいSurfaceZoneを選んだあとパラメータを入力（①～
⑤）してApplyボタン（⑥）をクリックします。 ここでは各パラメータ
を① 最も外側の層の格子幅を0.01② 層の総数を10層③ そのうち格子幅
が一定の層を外側から3層④ ①②で指定した残り内側7層の格子幅を1.2
倍ずつ積算する ⑤次節参照で指定しています。
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Boundary Layer

分割された（①）のでウィンドウのCancelボタンやXボタンでBoundary Layer
ウィンドウを閉じます（②）。

例4.21 押し込まれるNodeの移動距離を制限する（Add/Edit(Push)モード）

挿入された境界層の全体の格子幅が指定Surface Zoneに対するメッシュ
全体の格子幅に比べて大きい場合、図のように押し込まれた内部のNode
が反対側に飛び出てしまったりCellが反転してしまったりすることがあり
ます。 そんなときはAdjustment Limitの設定を調整し、内部のNodeが押
し込まれる距離を抑制する必要があります。

Adjustment LimitのFactorは内部点が移動できる距離を境界層全体の厚さとの
比で制限します。 ここでは前の図では境界層の厚さの3倍まで移動可能だった
のを1.3倍までに制限して、Cellの反転や内部点が反対から飛び出すのを防いで
います。
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Boundary Layer

例4.22 任意のSurface Zoneの内側に指定した格子幅の境界層を挿入する（Add（Split）
モード）

境界層を挿入したいSurface Zoneを選んだあと、パラメータを入力しま
す。 ここでは、下記の通り指定しています。

• Boundary Cell Height: 最も外側の層の格子幅を0.01

• Number Of Layer Cells:　層の総数を10層

• Number Of Uniform Cells:　そのうち格子幅が一定の層を外側から３
層

• Growth Factor:　上記で指定した残り内側7層の格子幅を1.2倍ずつ積
算する

• Adjustment Limit:　次節参照
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Boundary Layer

挿入されたのでBoundary Layerウィンドウを閉じます。

例4.23 既に存在する境界層を分割しなおす（Divideモード）

図のようにすでに存在している境界層を再分割します。
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Boundary Layer

境界層を再分割したいSurface Zoneを選んだあと、①モード選択タブをDivide
にします。②再分割する境界層の数を指定します。③再分割後の境界層の数を
指定します。④等分割するか指定します。⑤Applyボタン（⑤）で実行しま
す。ここでは既にsphere-surface直下に10層あるうちの4層を12層に等分割し
なおすように指定しています。

再分割されたのでBoundary Layerウィンドウを閉じます。
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Boundary Layer

例4.24 既に存在する境界層を消去する（Deleteモード）

図のようにすでに存在している境界層を消去します。

境界層を消去したいSurface Zoneを選んだあと、①モード選択タブをDeleteに
します。②消去する境界層の数を指定します。③消去に伴う内部点の移動の制
限をAdd/Edit(Push)モードのときと同様に決定します。④Applyボタンで実行
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Boundary Layer

します。 ここでは既にsphere-surface直下に10層あるうちの6層を消去するよ
うに指定しています。

消去されたのでBoundary Layerウィンドウを閉じます。
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Extrude

4.8.4. Extrude

メッシュの境界面を延長する
指定した境界面を延長するほか、延長した部分の境界面
を別のゾーンとして分別したり延長部分の分割密度を指
定できます。

操作方法

1. [メニューバー]→[Edit]→[Extrude]

2. 延長する境界面の選択

3. 詳細設定をしてApplyボタンをクリック
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Extrude

• Select: Surface Zone 選択ウィンドウを開く

• Extension Span

◦ length: 延長する長さを直接指定

◦ Ratio: 延長する長さをSurface Zone のサイズ比から指定

◦ Circle: Surface Zone サイズの計測を（円／矩形） とみなす

• Interval Count

◦ Number of Cells: 延長距離内におさまるCell の個数で延長格子間隔を計
算

◦ Maximum Growth Factor: 最大格子間隔比で延長格子間隔を計算

◦ First Uniform Cells: 格子幅一定となる始端側のCell 数

◦ Last Uniform Cells: 格子幅一定となる終端側のCell 数

• Cell Size

◦ Uniform Distribution: 延長格子間隔を一定にする

◦ First Size: 始端側の格子幅を指定して延長格子間隔を決定

◦ Last Size: 終端側の格子幅を指定して延長格子間隔を決定 （非推奨）

◦ First Size Ratio: 始端側の格子幅をSurface Zone に垂直な格子幅の代表
値との比で指定し延長格子間隔を決定。 Surface Zone に面するCell の格
子幅の代表値を （平均／最小／最大）からとる。

• Extension Direction

◦ Average Normal: 延長方向を Surface Zone の平均法線方向 とする

◦ Face Normal: 延長方向を各 Face の法線方向とする

◦ Set Vector 延長方向を直接指定した方向とする

• Create New Zone: 延長部分を新しいSurface Zone にする

103



Extrude

例4.25 境界層を延長するSurface Zoneを指定する

メニューバーのEdit→ Extrude …を選択します。

Extrude Boundary Surfaceが開くので、対象Surface Zoneを選択するために
Selectボタンをクリックします。

Add Boundary Layerウィンドウが開きます。 リスト内を選択して「>」ボタン
で移動させる、またはメッシュ画面で対象ゾーンをダブルクリックし
て、Selected Zonesのリストに移動させます。 対象Surface Zoneをすべて右側
のリストに入れたらApplyボタンをクリックします。 ここではoutflow-aux-1
及びoutflow-aux-2を対象とし、その外側に境界層を延長します。
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Extrude

対象Surface Zoneがリストに追加されました。
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Extrude

例4.26 SurfaceZoneの外側に指定した長さで境界層を延長する

境界層を延長したいSurface Zoneを選んだあとパラメータを入力して
Applyボタンをクリックします。 指定されたSurface Zoneが延長される
のでCancelボタンでExtrude Boundary Surface ウィンドウを閉じます。
ここでは各パラメータはデフォルト状態で実行しています。
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Extrude

指定したSurface Zoneが外側に延長され境界層が追加されました。

例4.27 各オプションを変更する

Create New Zoneオプションを有効にすると延長後に追加される境界面に
新しいSurface Zoneが割り当てられます。以降、元あったSurfaceと追加
されたSurfaceの境界を視認しやすくするため、このオプションを有効に
してオプション変更による影響を比較していきます。

延長する長さを変更します。 Extension Span内のオプションを変更する
ことで延長される総長を変更することができます。 Lengthでは値を直接指定
し、Ratioでは延長対象のSurface Zone のスケール比で長さを指定します。 図
はRatioのLengthに変更し、長さを1.3にした結果です。
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Extrude

延長する境界層の数を変更します。 Interval Count内のオプションを
変更することで延長される境界層の数を変更することができます。 Number
of Cellsでは層の数を直接指定し、Maximum Grows Factorでは
Extension Spanで決定した総延長距離のもとで境界層の最大幅比が指定した値
になるように層の数を決定します。 図はNumber of Cells の値を50に増やした
結果です。境界層の分割が細かくなっています。

Cell Sizeオプションを変更することで始端や終端の幅を変更できます。
Uniform Distributionは境界層の幅が一定になり、First Sizeは始端側の幅
を、Last Sizeは終端側の幅を値で指定できます。First Size Ratioは始端側の幅
を延長元となったセルの幅との比で決定します。 図は始端の幅比を1.0から2.0
に変更した結果です。
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Extrude

Extension Directionオプションを変更することで境界層の延長方向を変更で
きます。 Average Normalは元のSurface Zoneの平均法線方向に延長しま
す。Face Normalは各Face毎の法線方向に対応するCell及び新しいFaceは延長
されます。Set Vectorは延長方向を直接指定できます。図はSet Vectorに変更
した結果です。
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Smooth

4.8.5. Smooth

メッシュを平滑化する
メッシュを平滑化することで余計についてしまった凹凸
や内部セルの偏りを解消できます。

操作方法

1. [メニューバー]→[Edit]→[Smooth]

2. 詳細設定をして Applyボタンをクリックする

• Select Target

◦ Surface: 表面の頂点を平滑化

◦ interior: 内部の頂点を平滑化

◦ Both: 両方の頂点を平滑化
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Smooth

• Option for Surface

◦ Feature Angle: 指定した角度以内の角度で面が隣接する部分は 平滑化し
ない

◦ Select Face Zone: 平滑化するSurface Zone を指定

• Smoothing Method 平滑化アルゴリズムを変更

◦ Mean: 単純平均

◦ Laplace: Laplace法

◦ Turbine: Turbine法　Mean,Laplaceよりも体積減少を抑える

• apply FEM: 未実装のオプション

• Coefficient: 平滑化の強度(0.0～1.0）

• Iteration: 平滑化の実行回数

例4.28 境界表面を平滑化する

右図のような凹凸のある境界面を平滑化する。

メニューバーのEdit→ Smooth …を選択します。
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Smooth

平滑化のアルゴリズムを選び、効果の強さを0.0から1.0の間で調整し、重ね掛
けの回数を決めます。Applyボタンをクリックします。

凹凸が軽減されました。
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Smooth

例4.29 Select Face Zoneオプション

Select Face Zoneオプションを有効にし平滑化させたいSurface Zoneを選
択すると選択したもののみ平滑化されます。

例4.30 Feature Angleオプション

Feature Angle を設定することで平滑化する稜線としない稜線を分けるこ
とができます。
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Smooth

Feature Angleを設定した場合の結果です。図のようにFeature Angleで設定し
た稜線周辺の頂点や面は平滑化されていません。

例4.31 内部の頂点を整列する

一見均一に等分割された立方体格子に見えます。

しかしInspection等を用いて内部をみるとメッシュに偏りや歪みが見られまし
た。 このような内部のメッシュを外側に合わせて整列させます。
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Smooth

Smoothウィンドウを開いたらSelect TargetをInteriorに変更して平滑化を実
行します。

内部のメッシュの偏りが軽減されました。
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Projection

4.8.6. Projection

別のメッシュを参照し投影してメッシュを
整形する

高精細で形状の再現度は高いがセルがない、分割に偏り
があるなどのそのままでは使うことができない表面メッ
シュを参照することで劣化したメッシュの元の形状に対
する再現度を向上させます。

操作方法

1. [メニューバー]→[Edit]→[Projection]

2. 参照元の表面メッシュを選択

3. Applyボタンをクリック

この図は粗いメッシュの各面をスムージングをせずに分割したものですが、こ
のまま球面として使うのでは誤差が大きいです。従ってより理想的な形状に近
いサーフェスデータを含んだSTLファイルを参照することによって頂点配置を
球面に近づけます。

参照する球面により近いSTLです。
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Projection

例4.32 劣化したメッシュを高精細なSTLをもとに整形する

メニューバーのEdit→ Boundary Layer… …を選択します。

Use Fileになっていることを確認し、参照元のファイルパスを入力し、Applyボ
タンで実行します。

参考STLに近い形状（球）に調整されました。
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Projection
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Surface ID

4.8.7. Surface ID

境界面のIDを変更する
境界面のIDの数は欠番の存在を許しているため未使用の
番号ならば自由に変更できます。

操作方法

1. [メニューバー]→[Edit]→[Surface ID]

2. 変更したい境界面と変更後の番号を設定

3. Applyボタンをクリック

ここでは”wall-pipe-2”のIDを10から7に変更します。メニューバーのEdit→
Surface ID…を選択します。
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Surface ID

変更したいSurface の New ID の欄をクリックして、変更したい番号を入力
し、Apply ボタンをクリックします。

wall-pipe-2”のIDが7に変更されました。
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Surface Name

4.8.8. Surface Name

境界面の名前を変更する
境界面の名前を変更できます。ただし半角スペース
は”_”に変換されます。

操作方法

1. [メニューバー]→[Edit]→[Surface Name]

2. 変更したい境界面と変更後の名前を設定

3. Applyボタンをクリック

ここでは”wall-pipe-1”及び”wall-pipe-2”の名前をそれぞれ”wall-pipe-Z”,
”wall-pipe-X”に変更します。 メニューバーのEdit→ Surface Name…を選択し
ます。
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Surface Name

変更したいSurface の New Name の欄をクリックして、変更したい名前を入力
し、Apply ボタンをクリックします。

Surface名が変更されました。
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Surface Type

4.8.9. Surface Type

境界面の種類を変更する
指定した境界面の種類を wall / pressure-inlet /
pressure-outlet / symmetry / velocity-inlet / mass-
flow-inlet / interface / outflow / axis から選択して変
更できます

操作方法

1. [メニューバー]→[Edit]→[Surface Type]

2. 変更する境界面と変更後の境界面の種類を設定

3. Applyボタンをクリック

Surface Type を Surface毎に変更します。メニューバーのEdit→ Surface
Type…を選択します。
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Surface Type

変更したいSurface の New Type の欄をクリックして、プルダウンメニューか
ら変更したいSurface Type を選択し、Apply ボタンをクリックします。

Surface Typeが変更されました。
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Block Type

4.8.10. Block Type

ブロックの種類を変更
指定したブロックの種類を fluid / solid から選択して変更
できます。

操作方法

1. [メニューバー]→[Edit]→[Block Type]

2. 変更するブロックと変更後のブロックの種類を設定

3. Applyボタンをクリック

複数のBlockで構成されているメッシュのそれぞれのBlock Type を変更しま
す。メニューバーの Edit→ Block Type…を選択します。
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Block Type

変更したいSurface の New Type の欄をクリックして、プルダウンメニューか
ら変更したいSurface Type を選択し、Apply ボタンをクリックします。

Block Typeが変更されました。
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Split Surface

4.8.11. Split Surface

境界面を複数の境界面に分割する
Feature角度で指定した稜線で区切られた境界面や構造
メッシュの開始、終了面などの情報から指定した境界面
を分割します。

操作方法

1. [メニューバー]→[Edit]→[Split Surface]

2. 境界面を分割する条件を設定

3. Splitボタンをクリック

例4.33 Feature角度をもとに境界面を分割する

Surface を面同士の角度で分割します。メニューバーのEdit→ Split
Surface …を選択します。
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Split Surface

Surfaceの境界としたい辺を面と面の間の角度から指定し、Split ボタンをク
リックします。

Feature Angleで指定した辺で囲まれた領域が新たなSurfaceとして分割されま
した。

例4.34 構造メッシュをもとに境界面を分割する

この図のように構造格子として設定されているメッシュの場合、その境
界面を格子インデックス各方向の始面、終面をもとに分割することがで
きます。
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Split Surface

Split by Structureを選択して、Splitボタンで実行します。

Surface Zoneが構造格子と同様に分割されました。

例4.35 分割する境界面を絞り込む①

Split Visible Face Only オプションを有効にすると
Feature Angleで区切られる稜線で囲まれた境界面のうちインスペクショ
ン等で表示されている部分のみ分割されます。

先ほどのような表示状態でSplitを実行すると、図のように部品穴などの表示さ
れている面に含まれなかった部分は分割されていません。
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Split Surface

例4.36 分割する境界面を絞り込む②

図のメッシュは直方体の内部の壁面に物体が存在するのをアイコンバー
のInside機能を用いて示しています。このようなある程度Surface Zone
が分かれているときSplit Surfaces Separatelyオプションを有効にすると
分割するSurface Zoneと分割しないSurface Zoneを指定したり、分割に
使用するFeature AngleをZone毎に設定することができます。

さきほどの設定で分割した図です。 よりFeature Angleを厳しくとった元
inner1の円筒部側面は細かく分割されていることがわかります。
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Split Cell Zone

4.8.12. Split Cell Zone

セルゾーンを分割する
複数ブロックに分かれているメッシュのセルゾーンをブ
ロックを基にして分割します。

操作方法

1. [メニューバー]→[Edit]→[Split Cell Zone]

2. 拡大元と拡大先ウィンドウをマウスで調整

例4.37 ブロックをもとにセルゾーンを分割する

左図のように複数のBlockで構成されているメッシュの Cell Zone をBlock
別に分割します。 メニューバーのEdit→Split Cell Zone をクリックしま
す。

メニューバーのEdit→Split Cell Zone をクリックします。
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Split Cell Zone

Blockと同じ名前でCell Zoneが分割されました。
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Unite Surfaces

4.8.13. Unite Surfaces

境界面を結合する
指定した複数の境界面同士を一つの境界面としてまとめ
ます。

操作方法

1. [メニューバー]→[Edit]→[Unite Surfaces]

2. 結合する境界面を選択

3. 結合後の境界面の名前と種類を決定

4. Applyボタンをクリック

例4.38 選択した境界面同士をひとつにまとめる

Surface を結合します。 ここでは”wall-pipe-1”と”wall-pipe-2”を結合
することにします。 メニューバーのEdit→Unite Surfaces …を選択しま
す。
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Unite Surfaces

図のようなウィンドウが開くので、Zonesのリストから結合したいSurfaceを選
択し、ボタンでSelected Zones に移動します。結合したいSurfaceをすべて
Selected Zones に収めたらApplyボタンをクリックします。Selected Zones か
ら取り除きたいZoneがあればボタンを使用します。
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Unite Surfaces

図のようなウィンドウが開くので、結合後のSurfaceの名前を入力し、Typeを
選択します。そしてUnitボタンをクリックします。

選択されたSurfaceが結合されました。
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Unite Cell Zones

4.8.14. Unite Cell Zones

セルゾーンを結合する
複数ブロックに分かれているメッシュのセルゾーンをブ
ロックを基にして分割します。

操作方法

1. [メニューバー]→[Edit]→[Unite Cell Zones]

例4.39 セルゾーンを一つにまとめる

Cell Zone を一つに結合します。メニューバーのEdit→ Unite Cell Zones
…を選択します。

Cell Zoneが結合されました。
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Merge Nodes

4.8.15. Merge Nodes

近接頂点などを統合する
指定した距離内にある近接節点同士をひとつにまとめま
す。また重複する境界面を境界面として残すか内部面と
して消去するか選択します。

操作方法

1. [メニューバー]→[Edit]→[Merge Nodes]

2. Previewボタンで統合される箇所の確認

3. 閾値の調整

4. Merge ボタンをクリック
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Merge Nodes

例4.40 Merge Duplicate Nodes and Faces ウィンドウの各機能

上から、

• Tolerance : 結合閾値

• Reset : 結合閾値を初期値に戻す

• Merge : 結合対象を選択

• Option

◦ Don’t Merge Nodes in Same Cell : 同一Cell内の頂点は結合しない

◦ Only Merge Boundary Nodes : 境界面のみ結合する

◦ Don’t Merge Nodes in Same Block : 同一ブロック内では結合しない

◦ Preview : 結合をプレビューする

◦ Merge : 結合を実行する

◦ Cancel : キャンセル

138



Merge Nodes

例4.41 近接頂点及び面を結合する

図のように近接したNodeやFaceを結合し一つのNodeとする手順を示し
ます。

メニューバーのEdit→ Merge Nodes…を選択します。

Previewボタンをクリックして現在の設定で結合される箇所を確認します。 結
合箇所の過不足があればToleranceを調整します。 Toleranceの調整が充分でき
たらMergeボタンをクリックして結合を実行します。
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Merge Nodes

結合結果が表示されます。

近接Nodeが結合され一つのNodeとなりました。 また近接面同士だった境界面
だったinflowも結合によってなくなりました。

例4.42 近接頂点のみを結合する

Nodeのみを結合しFaceを残すにはNodes Onlyを選択します。この状態で
Mergeを実行します。
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Merge Nodes

Nodeのみが結合されます。図のようにNodes and Facesを選択しなくなってい
たSurface Zoneのinflowも残っていることがわかります。
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Fuse Surfaces

4.8.16. Fuse Surfaces

近接した重複面を統合する
指定した境界面のうち近接した面を統合し節点同士を結
合します。

操作方法

1. [メニューバー]→[Edit]→[Fuse Surfaces]

2. 統合する境界面を選択する

3. トレランスを調整する

4. Applyボタンをクリック

例4.43 近接する境界面を結合させる

図のようにほぼ同形状な面同士が近接した状態で配置された二つのパー
ツを結合させます。 なお、ここでは比較のため図左下の近接面のみを結
合させます。

メニューバーから「Edit」→「Fuse Surfaces」を選択します。
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Fuse Surfaces

Fuse Surfacesウィンドウが表示されるので、まず結合させる境界面を選択し
ます。

Selectボタンをクリックします。

境界面ゾーンの選択ウィンドウが開くので近接している面があるゾーンを選択
します。

ここではoutflow-1-2とinflow-2-2を選択します。

Applyボタンをクリックします。
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Fuse Surfaces

選択されたゾーンがFuse SurfaceウィンドウのSelected Boundary Listに登録
されます。

Tolerance Ratioにモデルサイズに対する節点が取りうる誤差の比を入力して
Applyボタンをクリックします。

結合処理が終了すると結合された節点と境界面の数が表示されます。OKボタン
を押してダイアログを閉じます。

Fuse SurfacesウィンドウもCancelボタンをクリックして閉じます。 すると図
のように左下の近接していた境界面が統合されなくなっていることが確認でき
ます。
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Scale

4.8.17. Scale

メッシュの大きさを変更する
拡大倍率を指定してメッシュの大きさを変更するほか、
軸ごとに拡大率を指定して変形させることもできます。

操作方法

1. [メニューバー]→[Edit]→[Scale]

2. 拡大、縮小倍率を設定する

3. Scaleボタンをクリックする

例4.44 メッシュの大きさを変更する

メッシュのサイズを変更します。操作の前に変更点をわかりやすくする
ためにここでは右クリックメニューのBounding Boxを表示させていま
す。（必須ではありません）

メニューバーのEdit→ Scale …を選択します。
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Scale

図のようなウィンドウが開くので、変更したい倍率を入力し、Scaleボタンを
クリックします。

メッシュのサイズが変更されました。
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Scale

例4.45 各軸個別に倍率を変える

Detailsにチェックをいれることにより、軸方向別に拡大縮小する倍率を
変えることができます。ここではY軸方向のみ3.0倍に拡大してみます。

メッシュのサイズがY軸のみ3.0倍に変更されました。
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Move

4.8.18. Move

メッシュの位置を変更する
メッシュの位置を移動、回転、反転移動できます。

操作方法

1. [メニューバー]→[Edit]→[Move]

2. 移動法、移動方向などの各種数値を設定する

3. Moveボタンをクリックする

例4.46 Moveウィンドウを開く

メッシュの座標を変更します。 操作の前に変更点をわかりやすくするた
めにここでは右クリックメニューのBounding Boxを表示させています。
（必須ではありません）

メニューバーのEdit→ Move …を選択します。
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Move

左図のようなダイアログが開きます。 Moveには平行移動、回転移動、反転移
動の三種類があります。
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Move

例4.47 平行移動

Translateを指定し、移動量を入力した後に、Moveボタンをクリックし
ます。
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Move

メッシュがx軸方向に1だけ移動しました。
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Move

例4.48 回転移動

Rotateを指定し、回転角と回転軸を入力した後に、Moveボタンをクリッ
クします。 回転軸にOtherを選択すると[Position]が入力可能になり、回
転軸の通る点と回転軸の方向を与えることで自由に回転軸を設定できま
す。
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Move

メッシュがz軸方向に30度だけ回転しました。
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Move

例4.49 反転移動

Reflectを指定し、鏡面を選択した後に、Moveボタンをクリックしま
す。 鏡面にOtherを選択すると[Position]が入力可能になり、鏡面上の点
と鏡面の法線ベクトルを与えることで自由に鏡面を設定できます。
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Move

メッシュがxy平面に対して反転しました。
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Copy

4.8.19. Copy

複製したメッシュを指定位置に追加する
複製したメッシュを移動、回転、反転させて元のメッ
シュに追加することができます。

操作方法

1. [メニューバー]→[Edit]→[Copy]

2. 複製後のメッシュの位置や複製の仕方などを設定する

3. Copyボタンをクリックする

例4.50 Copyウィンドウを開く

メッシュの複製をします。メニューバーのEdit→ Copy …を選択します。
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Copy

図のようなダイアログが開きます。 CopyにはMoveと同様に平行移動、回転移
動、反転移動をして複製するという三種類があります。
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Copy

例4.51 平行移動して複製

Translateを指定し、複製する数を与え、移動量を入力した後に、Copyボ
タンをクリックします。

158



Copy

メッシュがxy平面に対して反転しました。
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Copy

例4.52 回転移動して複製

Rotateを指定し、複製する数を与え、回転角と回転軸を入力した後
に、Copyボタンをクリックします。 回転軸にOtherを選択すると
[Position]が入力可能になり、回転軸の通る点と回転軸の方向を与える
ことで自由に回転軸を設定できます。
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Copy

メッシュがz軸方向に30度ずつ回転されて2つ分複製されました。
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Copy

例4.53 反転移動して複製

Reflectを指定し、鏡面を選択した後に、Copyボタンをクリックします。
鏡面にOtherを選択すると[Position]が入力可能になり、鏡面上の点と鏡
面の法線ベクトルを与えることで自由に鏡面を設定できます。
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Copy

メッシュがxy平面に対して反転したものが複製されました。
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Delete Visible

4.8.20. Delete Visible

メッシュの表示されている部分を消去する
インスペクションなどメッシュを部分的に表示非表示に
できる機能を使ってメッシュの不要な部分を削減しま
す。EditメニューのDelete Invisibleとは逆になっていま
す。

操作方法

1. インスペクションタブに切り替える

2. 消去する部分のみを表示するように各種数値を調整する

3. [メニューバー]→[Edit]→[Delete Visible]

例4.54 座標値でセルを消去する

表示されている部分を削除します。 前準備としてInspectionタブを開
き、消したい部分が表示されるように設定します。

メニューからEdit→ Delete Visibleを選択します。
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Delete Visible

表示されていた部分が削除されました。
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Delete Invisible

4.8.21. Delete Invisible

メッシュの表示されていない部分を消去す
る

インスペクションなどメッシュを部分的に表示非表示に
できる機能を使ってメッシュの不要な部分を削減しま
す。EditメニューのDelete Visibleとは逆になっていま
す。

操作方法

1. インスペクションタブに切り替える

2. 消去する部分のみを非表示するように各種数値を調整する

3. [メニューバー]→[Edit]→[Delete Invisible]

例4.55 座標値でセルを消去する

表示されている部分以外を削除します。 前準備としてInspectionタブを
開き、残したい部分が表示されるように設定します。
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Delete Invisible

メニューからEdit→ Delete Invisibleを選択します。

表示されていない部分が削除されました。
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Viewメニュー

4.9. Viewメニュー

4.9.1. Magnify

メッシュの一部を拡大表示する
メッシュを平滑化することで余計についてしまった凹凸
や内部セルの偏りを解消できます。

操作方法

1. [メニューバー]→[View]→[Magnify]

2. 拡大元と拡大先ウィンドウをマウスで調整

ViewメニューからMagnifyを選択します。

拡大元の矩形領域と拡大先のウィンドウが表示されます。
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Magnify

拡大元と拡大先ウィンドウの枠線にマウスポインタを近づけるとポインタの形
状が矢印に変わります。その状態でマウスの右ボタンを押しながらドラッグす
ることで、領域の大きさを変更することができます。

拡大元と拡大先の領域内にマウスポインタを移動すると、ポインタ形状が十字
型の矢印に変わります。その状態でマウスの右ボタンを押しながらドラッグす
ることで、ウィンドウの位置を変更することができます。
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Magnify Config

4.9.2. Magnify Config

Magnify機能の枠線の色や太さ、表示方法を変更して
メッシュが密集している箇所の見やすさを向上させま
す。特に1.9.16以降で追加されたMagnify枠内外での表
示の仕方をそれぞれ変更する操作方法については別項「
表示潰れを解消する1」をご参照ください。

操作方法

1. [メニューバー]→[View]→[Magnify]でMagnify機能を有効にする

2. [メニューバー]→[View]→[Magnify Config]で設定ウィンドウを開く

3. 各項目を変更

4. Closeボタンで設定ウィンドウを閉じる

Magnify ConfigではMagnify で表示される枠の設定ができます。

枠線の太さ、枠線の色を設定できます。

Apply をクリックすると反映されます。

1 http://www.quickmesh.co.jp/release-note/1-9-16/magnify-config.html
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Magnify Config
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Create View

4.9.3. Create View

Viewを作成する
QuickMeshではメッシュを表示したときの視界を再現す
るためにQuickMeshを起動している間視点の状態を保持
する機能があり、その保持した状態一つ一つをViewと呼
びます。Create Viewは現在の視点状態をもとに新たに
Viewを追加して、後述のSelect Viewで視点変更後も
View作成時の視界を再現できるようにします。

操作方法

1. [メニューバー]→[View]→[Create View」

2. View名を設定してOKボタンをクリック

ViewメニューのCreate Viewをクリックします。

ダイアログが表示されるので新しく作るViewの名前を入力してOKボタンをク
リックします。 その時の画面の視点を元にしたViewが作られます。 作った
ViewはSelect ViewやAdd/Manage View機能で利用できます。
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Select View

4.9.4. Select View

Viewを再現する
Create Viewで保持したViewやFileメニューのImport
View Statusで読み込んだViewなど、現在QuickMeshが
保持しているViewの中からひとつ選び、そのViewの視点
の状態を再現します。

操作方法

1. [メニューバー]→[View]→[Select View]にマウスポインタをあわせる

2. View名を設定してOKボタンをクリック

Create Viewを利用した後、画面の視点を変えたものとして説明をします。
ViewメニューのSelect ViewからCreate Viewで作ったview-1をクリックしま
す。

視点がview-1を作った時のものに戻ります。
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Add / Manage View

4.9.5. Add / Manage View

Viewを編集する
Create Viewで保持したViewやFileメニューのImport
View Statusで読み込んだViewなど、現在QuickMeshが
保持しているViewの中からひとつ選び、そのViewの視点
の状態を再現します。

操作方法

1. [メニューバー]→[View]→[Add/Manage View]

2. 操作したい項目のタブをクリック

3. 各種操作をする

4. cancelボタンで閉じる

例4.56 Viewを追加する

Create Viewを利用したものとして説明をします。 ViewメニューのAdd/
Manage Viewをクリックします。
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Add / Manage View

View Add/Managerが表示されます。 Addタブを選択し、新しく作りたいView
の名前を入力した後Createボタンをクリックします。 その時の視点を元にした
Viewが作られます。

例4.57 View名を変更する

Renameタブを選択します。 Old Nameから名前を変更したいViewを選択
し、New Nameで新しい名前を入力します。 Renameボタンを押します。

例4.58 Viewを編集する

Editタブを選択します。 Nameから編集したいViewを選んでそれぞれの
項目を編集します。 Applyボタンをクリックすると編集された内容が適
用されます。 Resetボタンをクリックすると編集前の値に戻ります。

175



Add / Manage View

例4.59 Viewを削除する

Deleteタブを選択します。 Nameから削除したいViewを選択し、Delete
ボタンをクリックします。
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In-plane Rotation

4.9.6. In-plane Rotation

画面に垂直な軸で視点を回転する
デフォルト状態のQuickMeshではマウスの左ドラッグで
視点を回転させると、視点は画面と平行な軸回転しま
す。しかしIn-Plane RotationをONの状態にしていると、
画面と垂直な軸すなわち視線を軸に視界が回転するよう
になります。

操作方法

1. [メニューバー]→[View]→[In-plane Rotation]をクリックでON

2. マウスで左ドラッグをする

3. 再び[メニューバー]→[View]→[In-plane Rotation]をクリックでOFF

ViewメニューのIn-plane Rotationをクリックするとマウスのドラッグによる
回転操作の回転軸が画面に垂直な方向に切り替わります。つまり、画面の表す
平面上での回転になります。これを解除するにはもう一度ViewメニューのIn-
plane Rotationをクリックします。

In-plane Rotationモードで回転している様子です。
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Coordinate Axis

4.9.7. Coordinate Axis

座標軸の表示を切り替える
画面左下にある座標軸方向を示すオブジェクトの表示の
ON/OFFを切り替えます。

操作方法

1. [メニューバー]→[View]→[Coordinate Axis]をクリックでOFF

2. 再び[メニューバー]→[View]→[Coordinate Axis]をクリックでON

Coordinate Axisをチェックすることで座標軸の表示非表示が切り替わります。
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Bounding Box

4.9.8. Bounding Box

Bounding Boxの表示を切り替える
メッシュ全体を座標軸に平行な平面で作られる直方体で
覆った際この直方体をBounding Boxと呼び、これを表示
すると直方体の各頂点座標と各辺の長さが表示されるた
めメッシュが存在する範囲や大きさをおおまかに調べる
のに役立ちます。

操作方法

1. [メニューバー]→[View]→[Bounding Box]をクリックでON

2. 再び[メニューバー]→[View]→[Bounding Box]をクリックでOFF

Bounding Boxをチェックすることでメッシュを取り囲む直方体の表示/非表示
が切り替わります。
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Rotation Center

4.9.9. Rotation Center

回転中心の表示を切り替える
メッシュ全体を座標軸に平行な平面で作られる直方体で
覆った際この直方体をBounding Boxと呼び、これを表示
すると直方体の各頂点座標と各辺の長さが表示されるた
めメッシュが存在する範囲や大きさをおおまかに調べる
のに役立ちます。

操作方法

1. [メニューバー]→[View]→[Rotation Center]をクリックでON

2. 再び[メニューバー]→[View]→[Rotation Center]をクリックでOFF

回転中心を表示します。 表示した回転中心がわかりやすいようにデフォルトの
Face表示からWire表示に切り替えています。 メニューバーのViewメニューか
らRotation Centerを選択します。

赤い点として視点の回転中心が表示されました。 この表示は再びRotation
Centerメニューをクリックすることでオフになります。
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Highlight Surface

4.9.10. Highlight Surface

マウスポインタ下の境界面をハイライトす
る

この機能をONにしているときメッシュ画面でモデルにマ
ウスポインタを合わせると、ポインタが載っている境界
面がハイライトされて表示されます。

操作方法

1. [メニューバー]→[View]→[Highlight Surface]をクリックでON

2. 再び[メニューバー]→[View]→[Highlight surface]をクリックでOFF

Highlight Surfaceをクリックするとマウスポインタ下の境界面がハイライト表
示されます。 ハイライト表示を止めるにはもう一度Highlight Surfaceをクリッ
クします。

ハイライト表示をすると図の様になります。
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Cell Index

4.9.11. Cell Index

セル番号を表示する
全てのセル番号を表示します。また右クリックで表示さ
れるメニュー内にあるCell Indexと同じ機能です。

操作方法

1. [メニューバー]→[View]→[Cell Index]または、モデル画面を右クリック
→[Cell Index]をクリックでON

2. 再び[Cell Index]メニューをクリックでOFF

ViewメニューのCoordinate Axisをチェックすることでセル番号の表示/非表示
が切り替わります。
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Node Index

4.9.12. Node Index

ノード番号を表示する
選択したノードの番号を表示します。また右クリックで
表示されるメニュー内にあるNode Indexと同じ機能で
す。

操作方法

1. [メニューバー]→[View]→[Node
　Index]またはモデル画面を右クリック→[Node Index]をクリックでON

2. Node Selection Optionsウィンドウで頂点の選択方法を切り替え

3. マウスで節点を選び番号を表示する

4. Node Selection Optionsウィンドウを閉じるか再び[Node Index]メニュー
をクリックでOFF

ViewメニューのNode IndexをチェックするとNode Selection Optionsウィンド
ウが表示され、それで選択されたノードの番号を表示します。 Node Selection
Optionsウィンドウの使い方を参照してください。
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Node Coordinate

4.9.13. Node Coordinate

ノード座標を表示する
選択したノードの位置座標を表示します。また右クリッ
クで表示されるメニュー内にあるNode Coordinateと同じ
機能です。

操作方法

1. [メニューバー]→[View]→[Node
　Coordinate]またはモデル画面を右クリック→[Node Coordinate]をク
リックでON

2. Node Selection Optionsウィンドウで頂点の選択方法を切り替え

3. マウスで節点を選び番号を表示する

4. Node Selection Optionsウィンドウを閉じるか再び[Node Coordinate]メ
ニューをクリックでOFF

ViewメニューのNode CoordinateをチェックするとNode Selection Options
ウィンドウが表示され、それで選択されたノードの座標を表示します。 Node
Selection Optionsウィンドウの使い方を参照してください。
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Node to Node Distance

4.9.14. Node to Node Distance

ノード間の距離を表示する
選択した２つのノードを直線で結んだ距離を表示しま
す。また右クリックで表示されるメニュー内にあるNode
to Node Distanceと同じ機能です。

操作方法

1. [メニューバー]→[View]→[Node　to Node Distance]またはモデル画面を
右クリック→[Node to Node Distance]をクリックでON

2. マウスで始点となる節点を選択

3. マウスで終点となる節点を選択

4. 再び[Node to Node Distance]メニューをクリックでOFF

ViewメニューのNode to Node Distanceをチェックするとノードがクリックで
選べるようになります。

始点と終点を選択すると、ノード同士が赤い直線で結ばれ、ノードの位置座標
とノード間の距離が表示されます。

185



Node Selection Options

4.9.15. Node Selection Options

ノードを複数選択する
Node Selection OptionsウィンドウはNode IndexやNode
Coordinateで複数のノードをユーザーが任意で選択でき
る場合に表示されるウィンドウです。マウスカーソルで
クリックしたノードを選択に加えるSingle選択、ドラッ
グした範囲内にあるノードを選択に加えるBox選択、全て
選択するAll選択、選択を解除するClearがあります。

操作方法

1. [メニューバー]→[View]→[Node Index]などノードを選択する機能を使用
する

2. 開いたNode Selection Optionsウィンドウでノードの選択法を設定

3. ノードを選択する

例4.60 ノードをマウスカーソル下から選択する

今回は例としてViewメニューのNode IndexをクリックしてNode
Selection Optionウィンドウを出したとして説明します。Node Selection
OptionsウィンドウのSingleをクリックすると、マウスカーソルの下にあ
るノードをハイライト表示します。クリックするとハイライトされた
ノードを選択します。
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Node Selection Options

例4.61 ノードを矩形選択する

Node Selection OptionsウィンドウのBoxをクリックすると、マウスカー
ソルのドラッグ時に矩形が表され、その中にあるノードが選択されま
す。

例4.62 ノードを全て選択する

Node Selection OptionsウィンドウのAllをクリックすると、全てのノー
ドが選択されます。
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Node Selection Options

例4.63 ノードの選択を解除する

Node Selection OptionsウィンドウのClearをクリックすると、ノードの
選択が取り消されます。
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Duplicate Nodes

4.9.16. Duplicate Nodes

近接するノードを表示する
許容誤差を与えて、その値以下の距離にある同士のノー
ドをハイライト表示します。

操作方法

1. [メニューバー]→[View]→[Duplicate Nodes]を選択する

2. 許容誤差を設定し、Updateボタンをクリックする

ViewメニューのDuplicate NodesをクリックするとDisplay Duplicate Nodes
ウィンドウが表示されます。 Updateボタンを押すと重複しているノードをハ
イライト表示します。また、Tolerance で許容する誤差を与えることができま
す。
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Duplicate Faces

4.9.17. Duplicate Faces

近接する面を表示する
許容誤差を与えて、各頂点の距離がその値以下の距離に
ある面をハイライト表示します。

操作方法

1. [メニューバー]→[View]→[Duplicate Faces]を選択する

2. 許容誤差を設定し、Updateボタンをクリックする

ViewメニューのDuplicate FacesをクリックするとDisplay Duplicate Facesウィ
ンドウが表示されます。 Updateボタンを押すと重複している面をハイライト
表示します。 また、Toleranceで許容する誤差を与えることができます。
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Reset View

4.9.18. Reset View

視点を初期状態に戻す
メッシュを表示する視点をメッシュ読み込み時などの初
期状態に戻します。

操作方法

1. [メニューバー]→[View]→[Reset View]を選択する

ViewメニューのReset Viewをクリックすると、視点は初期状態に戻されます。
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Reportメニュー

4.10. Reportメニュー

4.10.1. Global Region

数値としてメッシュ全体の存在位置を表示
する

メッシュ全体の存在領域や中心、幅などを数値データと
して表示します。

操作方法

1. [メニューバー]→[Report]→[Global Region]を選択する

各項目でメッシュが存在する範囲や位置、幅が座標方向ごとに表示されます。

• Minimum : 各座標の最小値境

• Maximum : 各座標の最大値

• Center : 各座標の中央値

• Width : 各座標方向の幅

192



Boundary Region

4.10.2. Boundary Region

数値として境界面ごとのメッシュの存在位
置を表示する

境界面ごとに存在領域や中心などを数値データとして表
示します。

操作方法

1. [メニューバー]→[Report]→[Boundary Region]を選択する

各項目でメッシュが存在する範囲や位置、幅が境界面ごとに表示されます。

• ID : 境界面のID

• Name : 境界面の名称

• Type : 境界面の種類

X,Y,Z は、各座標方向の数値データ。左から順に最小値、最大値、中央値とな
る。
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Boundary Surface

4.10.3. Boundary Surface

数値として境界面の面としての情報を表示
する

境界面ごとの面積や境界面が含む面メッシュの枚数や、
最大面積、最小面積、平均面積、形状別の枚数が表示さ
れます。

操作方法

1. [メニューバー]→[Report]→[Boundary Surface]を選択する

• ID : 境界面のID

• Name : 境界面の名称

• Type : 境界面の種類

• Area : 境界面の総面積

• Volume : 閉領域の体積（全体のみ）

• Face Area

◦ Minimum : 表面メッシュの最小面積

◦ Maximum : 表面メッシュの最大面積

◦ Average : 表面メッシュの面積の平均値

• Number of Faces

◦ Triangle : 三角形表面メッシュの数

◦ Quad : 四角形表面メッシュの数

◦ Other : その他の形状の表面メッシュの数

◦ Total : 表面メッシュの数
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Volume Region

4.10.4. Volume Region

数値としてセルゾーンごとのメッシュの存
在位置を表示する

セルゾーンごとに存在領域や中心、幅などを数値データ
として表示します。

操作方法

1. [メニューバー]→[Report]→[Volume Region]を選択する

各項目でメッシュが存在する範囲や位置、幅が境界面ごとに表示されます。

左から、セルゾーンのID、セルゾーンの名称、セルゾーンの種類。

X、Y、Zの値は、 セルゾーンが存在する範囲の各座標方向の数値データ。左か
ら順に最小値、最大値、中央値となる。
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Volume Cell

4.10.5. Volume Cell

数値としてセルゾーンごとの体積を表示す
る

セルゾーンごとに体積や、セルの体積の最大最小平均
値、セルの種類と個数を表示します。

操作方法

1. [メニューバー]→[Report]→[Volume Cell]を選択する

各項目でセルゾーンごとの統計が表示されます。

左から、セルゾーンのID、セルゾーンの名称、セルゾーンの種類、セルゾーン
の体積。

• Cell Volume : セルごとの体積の統計

左から最小、最大、平均値。

• Number of cells : セルの種類ごとの個数

左から四面体、三角柱、四角錐、六面体、その他、合計。
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Block Region

4.10.6. Block Region

数値としてブロックごとの構造メッシュの
存在範囲を表示する

ブロックごとに構造メッシュの存在範囲をxyz座標値の最
大、最小値で表示します。なおこの操作は現在のメッ
シュが構造メッシュとなっているときのみ有効です。

操作方法

1. 構造メッシュファイルを読み込む、または[メニューバー]→[Tools]→[Set
Structured Index]で現在のメッシュを構造メッシュ化する

2. [メニューバー]→[Report]→[Block Region]を選択する

各項目で構造メッシュが存在する範囲や中心値がブロックごとに表示されま
す。

左から、ブロックのID、ブロックの種類。

X、Y、Z の値は、ブロックが存在する範囲の各座標方向の数値データ。左から
順に最小値、最大値、中央値となる。
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Block Dimension

4.10.7. Block Dimension

数値としてブロックごとの構造メッシュの
存在範囲を表示する

ブロックごとに構造メッシュがI,J,K方向にいくつセルが
あるかを表示します。なおこの操作は現在のメッシュが
構造メッシュとなっているときのみ有効です。

操作方法

1. 構造メッシュファイルを読み込む、または[メニューバー]→[Tools]→[Set
Structured Index]で現在のメッシュを構造メッシュ化する

2. [メニューバー]→[Report]→[Block Dimension]を選択する

各項目でブロックごとのI,J,K方向のセルの個数が表示されます。

左から、ブロックのID、セルゾーンの種類、NI, NJ, NK各方向のセルの個数、
セルの合計数。
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Skewness

4.10.8. Skewness

数値としてセルの種類ごとにセルの歪度を
表示する

セルの種類（四面体、四角錐、三角柱、六面体）ごとに
セルの歪度の統計値をそれぞれ表示します。なおここで
はセルの歪度を、セルの面の各頂点の角度と、同じ頂点
数の正多角形の内角との差のうち最大値とします。

操作方法

1. [メニューバー]→[Report]→[Skewness]を選択する

左から順に四面体、四角錐、三角柱、六面体、全体でセルの種類ごとに歪度の
各統計値を表示します。

上から、歪度の最小値、最大値、平均値、標準偏差。
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Aspect Ratio

4.10.9. Aspect Ratio

数値としてセルの種類ごとにセルのアスペ
クト比を表示する

セルの種類（四面体、四角錐、三角柱、六面体）ごとに
セルのアスペクト比の統計値をそれぞれ表示します。な
おここではセルのアスペクト比を、セルの各辺長の最大
値/最小値とします。

操作方法

1. [メニューバー]→[Report]→[Aspect Ratio]を選択する

左から順に 四面体、四角錐、三角柱、 六面体、全体でセルの種類ご とにアス
ペクト比の各統計値を 表示します。

上から、アスペクト比の最小値、最大値、平均値、標準偏差。
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Volume Ratio

4.10.10. Volume Ratio

数値としてセルの種類ごとにセルの体積比
を表示する

セルの種類（四面体、四角錐、三角柱、六面体）ごとに
セルの体積比の統計値をそれぞれ表示します。なおここ
ではセルの体積比を、あるセルに対して各隣接セルにつ
いて、そのセルの体積と隣接セルの体積のうち大きい方
の体積/小さい方の体積を求め、全隣接セルのうち最大値
となるものとします。したがって体積比が大きいと、隣
接セル間での体積の変化が大きいということになりま
す。

操作方法

1. [メニューバー]→[Report]→[Volume Ratio]を選択する

左から順に四面体、四角錐、三角柱、六面体、全体でセルの種類ごとに体積比
の各統計値を表す。

上から、体積比の最小値、最大値、平均値、標準偏差。
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Jacobian

4.10.11. Jacobian

数値としてヤコビ行列の行列式のデータを
表示する

様々なヤコビ行列式に関する情報を表示します。この機
能は高次要素の時にのみ利用可能です。高次要素でない
メッシュに対して行いたい場合はあらかじめToolsメ
ニューのSet High-Order Elementsを行う必要がありま
す。

操作方法

1. 高次要素でできたメッシュファイルを読み込む。またはSet High-Order
Elementでメッシュを高次要素化する。

2. [メニューバー]→[Report]→[Jacobian]を選択する

セルごとに求めた次の各ヤコビ行列の行列式の最大値、最小値を示します。

左から、

• Center Jacobian : 中心点のヤコビアン

• Gauss Node Jacobian : ガウス点でのヤコビアン

• Jacobian Ratio : セル内ガウス点同士の最大比

• Scaled Jacobian : セル内各ガウス点ヤコビアン/セル体積

• Gauss Quadrature Volume : ガウス積分したセル体積
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Convertメニュー

4.11. Convertメニュー

4.11.1. 3D to 2D

3次元メッシュを投影して2次元メッシュに
する

3Dになっているメッシュの境界面を選択し、平面に投影
した2Dメッシュに変更します。

操作方法

1. [メニューバー]→[Convert]→[3D to 2D]

2. 境界面を選択してConvertボタンをクリック

図のような回転体にボリュームメッシュを詰めたようなメッシュから回転元の
2次元メッシュを取り出すのに3D to 2Dを利用します。

メニューバーのTools→Set Structured Boundaryを選択します。

境界面を選択します。 クリックした境界面はハイライトされます。 2次元メッ
シュとして取り出したい境界面を選択したらConvertボタンを押します。
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3D to 2D

選択した境界層が平面に投影されて2次元メッシュに変換されました。
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2D to 3D

4.11.2. 2D to 3D

2次元メッシュを押し出し/回転させて3次
元メッシュにする

2次元メッシュに対して距離を決めて押し出しで柱体の3
次元メッシュに変換したり、回転軸と角度を決めて回転
体の3次元メッシュに変換します。

操作方法

1. [メニューバー]→[Convert]→[2D to 3D]

2. Convert to 3Dウィンドウで押し出しか回転か選択する

3. その他詳細設定をする

4. Convertボタンを押す
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2D to 3D

例4.64 Convert to 3Dウィンドウ

① 押し出しで3D化

② 回転で3D化

③ 押し出し、回転での追加セル数

④ 押し出し距離

⑤ 回転角度

⑥ 軸方向、 左からX軸、Y軸、任意方向

⑦ 軸中心、 ⑥でOther選択時有効

⑧ 軸方向、 ⑥でOther選択時有効

⑨ 追加される境界面名称とタイプ

⑩ 変換実行ボタン
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2D to 3D

例4.65 2次元メッシュを押し出して3次元メッシュにする

図のようなXY平面上の2次元メッシュをZ軸方向に押し出して3次元メッ
シュにします。

メニューバーのConvert → 2D to 3Dを選択します。
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2D to 3D

Extrudeが選択されていることを確認し、Number of Cellsに押し出しでできる
セルの段数を指定します。

Thicknessで押し出し距離を設定します。

ここでは追加セル数を10段、押し出し距離を1.0とします。

Convertボタンをクリックします。
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2D to 3D

押し出しで10段のセルが距離1.0の間に追加され、3次元メッシュとなりまし
た。

2次元メッシュのとき視点から見えていた表面は境界面new_z_1とnew_z_2と
して新たに追加されています。

例4.66 2次元メッシュを回転させて3次元メッシュにする

図のようなXY平面上の2次元メッシュをY軸を中心に回転させて3次元
メッシュにします。

メニューバーのConvert → 2D to 3Dを選択します。
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2D to 3D

立体化の方式をRevolve(回転体)、回転軸をY軸に変更します。またここでは回
転方向の分割数を24、回転角度を360度に設定しています。 Convertボタンを
押してメッシュの回転体を作成します。
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2D to 3D

回転体の3Dメッシュが生成され、表示されました。

回転角を360度未満で設定していた場合、以上の操作で
指定角度まで回転した3次元メッシュを作成したメッシュ
が作成できます。しかし回転角を360度にし、完全な回
転体を作った場合、回転開始の表面メッシュ(new_z_1)
と回転終了の表面メッシュ(new_z_2)が重複して存在す
ることになります。重複面の存在が好ましくない場合、
次のような手順を追加で行う必要があります。

例4.67 回転開始と回転終了の重複を解消する

360度で回転させたため、プロパティタブで表面ゾーンの表示/非表示を
切り替えると内部でnew_z_1とnew_z_2が重複していることがわかりま
す。ここでは側面の表面ゾーンの表示を消したものを図示しています。
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2D to 3D

メニューバーのEdit → Merge Nodesを選択します。

特に設定は変えずにMergeボタンをクリックします。

重複が解消され内部面となるnew_z_1、new_z_2がなくなりました。
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Meshメニュー

4.12. Meshメニュー

4.12.1. Structured

非構造メッシュを構造メッシュに再分割す
る

非構造メッシュを再分割して四角形面(2D)や六面体セル
(3D)で構成される構造メッシュに変更し、指定した境界
面を始端、終端として面またはセルにインデックスを振
り分けます。 この操作は境界面の枚数が2Dメッシュなら
ば4つ以上、3Dメッシュならば6つ以上を必要とし、境界
面をインデックス端の数だけグループ分けして四角形ま
たは六面体と同位相のメッシュとなっている必要があり
ます。

操作方法

1. [メニューバー]→[Mesh]→[Structured]

2. 構造メッシュのインデックス始端、終端となる境界面を選択する

3. 分割数を指定してApplyボタンを押す
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Structured

例4.68 Subdivisionタブの各機能

• Unconnected Zones: 未振り分けZoneリスト

• Shift to From 上から、

◦ 振り分け先

◦ 振り分けボタン

◦ すべて振り分け

◦ 差し戻しボタン

◦ すべて差し戻し

• LowI : インデックス I 最小Zoneリスト

• HighI : インデックス I 最大Zoneリスト

• LowJ : インデックス J 最小Zoneリスト

• インデックス J 最大Zoneリスト

• NI : I 方向セル数

• NJ : J 方向セル数

• I space, J space : 分割間隔オプション

• Feature Angle : Feature点/線とする角度

• Option : 詳細設定

• Size Parameter : 間隔矯正パラメータ

• Hyperbolic Factor : 境界付近垂直矯正パラメータ
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Structured

例4.69 ２次元メッシュを構造メッシュに変更する

メニューバーの Mesh→ Structured…を選択します。

設定用のタブが開くので、各インデックスの始点、終点となるSurface Zoneを
選択します。 例）Surface Zone “a”を選択状態にして[ Low-I] のときに[>]を
押すことで”a”はインデックスIの始点となります。

“a”が移動Low Iの枠に移動しました。
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Structured

同様にHigh I, Low J, High J を振り分けたら構造格子のIインデックスの個数、J
インデックスの個数を入力します。

I方向に100個、J方向に10個セルが並んだ構造メッシュに分割されました。

例4.70 その他各オプション比較

赤枠内の設定項目で変化する点を図のメッシュで説明します。
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Structured

boundary surface付近のメッシュの分割間隔を変えます。

Auto: 特に指定しない。両側をAutoにするとメッシュの角は垂直に近くなる。

Uniform: 等間隔になるように分割される。

上の図ではLow-J側のI方向の切り方を均等にしています。

辺の角度がFeature Angle以下の角度となるBoundary Surface 上の頂点は必ず
保持されます。 上の図はFeature Angle を135度から10度に変更したところ、
直角な角になっていたところを保持されなくなったため、その特徴が失われて
います。

Size Parameter 値を大きくするとBoundarySur faceの曲面に対して内側に近づ
いていたメッシュの分割線が外側に膨らむようになります。 図は0.5のときで
す。
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Structured

Size Parameter （続き） 図は1.0のときです。

Size Parameter（続き）

図は2.0のときです。かなり大回りするようになりました。

Hyperbolic Factor 値を大きくすると、Boundary Surface 付近のメッシュの分
割が垂直に近くなります。図では、効果がわかりやすくなるようにI方向の
Uniformにして分割しています。Hyperbolic Factorが0なので境界付近のメッ
シュの分割は垂直から歪んだものになります。
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Structured

Hyperbolic Factor（続き） Hyperbolic Factorを5.0にしたら境界付近は垂直に
近づきましたが、その分内側のセルの歪みが大きくなっています。

Hyperbolic Factor（続き） Hyperbolic Factorを10.0にしました。さらに境界
付近は垂直に近づき内側のセルは歪みます。

例4.71 3次元非構造メッシュを構造メッシュに変更する

三次元非構造メッシュを構造メッシュに変更します。 なおこの操作は境
界面が6面以上あることが必要条件となります。
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Structured

2次元メッシュと同様に構造格子のそれぞれのインデックス方向となる境界面
を6つに振り分けます。 例）Surface Zone “a”をクリックで選択状態にし、
[Low-I]のときに [>で”a”はインデックスIの始点となります。

境界面“a”が移動Low Iの枠に移動しました。

同様にして境界面を全て振り分けます。 このとき各インデックス端面グループ
は四角形で構成される六面体のように接続され、Low-Highは対面同士となる
ようにします。 分割数を指定しApplyボタンを押します。
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Structured

3次元構造格子に分割されました。

Inspectionタブで内部セルを見ても六面体セルが規則的に並んでいることがわ
かります。

例4.72 その他オプション（3D）

3次元メッシュの場合では、開発中により、 Size Parameter以外のオプ
ション設定項目は制限されています。
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Structured

Size Parameterを大きくするとインデックス端面に集中していた分割線が広げ
られます。 図はデフォルト0だったものを1.0に変更した結果です。
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Single Block

4.12.2. Single Block

直方体メッシュを生成する
位置と分割数を指定して六面体セルのみで構成された直
方体状のメッシュデータを作成します。

操作方法

1. [メニューバー]→[Mesh]→[Single Block]

2. 座標と分割の仕方を設定する

3. 現在のメッシュと置き換えるか追加するかを指定する

4. Createボタンでを押す

直方体のセルのみで構成される直方体のメッシュを生成します。
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Single Block

• region : 生成されるメッシュの範囲を指定する方法を定めます。

◦ Minimum and Maximum : 生成する直方体の対角線の端点を与えます。

◦ Minimum and Length : 生成する直方体の最小の頂点とサイズを与えま
す。

◦ Center and Length : 生成する直方体の中心とサイズを与えます。

• Division : 生成されるメッシュの分割方法を定めます。

◦ Number of Divisions : メッシュをいくつに等分割するかを与えます。

◦ Element Size : 一つ分のセルの大きさを与えます。

◦ Global Mesh Size : Element Sizeを選択している時に有効で、生成したい
セルが立方体である場合にその立方体の一辺の長さを与えます。

• X, Y, Z : 上記で定めた方法に則って座標などを指定します。

• Append or Replace : 生成したメッシュを現在のメッシュと置き換えるか付
け加えるかを指定します。
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Single Block

生成した結果です。 分かりやすさの為にバウンディングボックスを表示してい
ます。
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Chamber

4.12.3. Chamber

燃焼室のメッシュを作成する
デモとして各種パラメータを任意に指定した燃焼室の
メッシュを作成します。

操作方法

1. [メニューバー]→[Mesh]→[Chamber]

2. 断面の2Dメッシュか、回転体の3Dメッシュかを指定する

3. 各種パラメータを調整する

4. Createボタンを押してメッシュを生成する

上から、 2D/3D 生成するのを断面か回転体かを指定。

Angle　→ 3D を選択したとき有効。回転体の角度を指定。
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Chamber

• Chamber Diameter: 円筒部の直径

• Throat Diameter: スロート部の直径

• Faceplate to Throat Distance: 円筒部+収縮部の長さ

• Shrink Curvature Radius: 円筒-収縮移行部の曲率半径

• Chamber Cylinder Length: 円筒部の長さ

• Throat Shrink Angle: 収縮部の角度

• Throat Expansion Angle: 膨張部の角度

• Throat Curvature Radius(Front): 収縮部の曲率半径

• Throat Curvature Radius(Back): 膨張部の曲率半径

• Expansion Length: 膨張部の長さ

• Exit Additional Length: 流出境界面からメッシュの終わり端までの長さ

• Number of Cells: 総セル数

• Set Each Direction: セル数の方向毎の設定を有効化

• Axis: 回転軸方向のセル数

• Radius: 回転半径方向のセル数

• Perimeter: 周回方向のセル数
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Chamber

• Shrink Curvature Radius 及びChamber Cylinder Length は独立でない変数
のため、一方を確定させるともう一方は自動で値が決定されます。

• Number of Cells で全体のセルの数を設定するとAxis、Radius、Perimeter
の各方向でのセル数は自動で決定されます。しかし、Set Each Direction の
チェックボックスにチェックを入れることで個別に設定できるようになりま
す。
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2D Mesh

4.12.4. 2D Mesh

輪郭線から2Dメッシュを作成する
ノードの座標を順に設定していくことで輪郭線を形成
し、その輪郭線で囲まれた閉領域を三角形または四角形
セルで埋めることで二次元メッシュを生成します。

操作方法

1. [メニューバー]→[Mesh]→[2D Mesh]

2. ノードの位置を指定して輪郭線を作る

3. Createボタンを押す

二次元のメッシュを生成します。

上から、

• X、Yの値 : 一つのノードの座標

• Division : 次のノードまでの辺の分割数
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2D Mesh

• Add : 末尾にノードを一つ加える

• Delete :末尾のノードを削除する

• Maximum Area : 面積の最大値

• Minimum Angle : 角度の最小値

• Preview : プレビューを表示

• Number of Cells : セルの数

• Structured : 構造メッシュにするかどうか

• Feature Angle :

• Quad-dominated Mesh :

• Load : 外部ファイルからデータを読み込む

• Save : 外部ファイルにデータを書き込む

• Create : メッシュを生成する

• Close : タブを閉じる

生成したいメッシュの輪郭を一周する順番にノードの座標を設定します。

それぞれのノード間についての分割数をDivisionに入力します。

Previewの際、ノード間をこの数で等分割した点にノードのあるメッシュが生
成されます。

Division最後の入力欄の値は最後のノードと最初のノードの間についての分割
数を指します。

輪郭を一周するのにノードが足りない場合、Addボタンをクリックすると末尾
にノードが追加されます。
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2D Mesh

ノードを増やしすぎた場合、Deleteボタンをクリックすると末尾のノードが削
除されます。

細かなメッシュを生成する前にPreview機能によって予め大まかなメッシュを
生成することができます。

Preview OptionではPreview機能で生成されるメッシュのセルについての設定
ができます。

Maximum Areaではセルの面積の最大値を、Minimum Angleではセルの内角の
最小値を与えることができます。

Number of Cellsは目標とするセル数。 structuredは構造メッシュを生成する
か否か（注意：この機能は現段階ではサポートされていません）。

Feature Angleは構造メッシュを生成する時のFeature Angle。

quad-Dominated Meshでは四角形で切られたメッシュを生成するか否か。 を
表します。
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2D Mesh

Loadボタンをクリックするとファイルオープンダイアログが開かれます。

選択されたファイルの拡張子からフォーマットが定まらない場合、図のような
フォーマットダイアログが出てきます。

読み込めるファイルフォーマットは、

●quickmeshが独自に定義したq2d

●ノードの座標を列挙したテキスト

●ノードの座標のCSV

の3つです。

Saveボタンをクリックするとq2d形式のファイルに書き出します。

Createボタンをクリックすると情報を元にメッシュを生成します。

Closeボタンをクリックすると2D Meshタブを閉じます。
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Toolsメニュー

4.13. Toolsメニュー

4.13.1. Set Structured Index

構造メッシュのインデックスを割り振る
構造メッシュに変換可能であるにも関わらず非構造メッ
シュの扱いになっているメッシュに構造メッシュとして
インデックスを付加することができます。

操作方法

1. [メニューバー]→[Tools]→[Set Structured Index]

2. Applyをクリック

非構造メッシュを構造メッシュに変換するために格子点を配置します。

この操作は構造メッシュに変換可能なメッシュでなければ失敗します。

このメッシュは非構造メッシュであり、そのためPropertyタブのBlockは有効
でありません。

Set Structured Indexをクリックすると右のようなダイアログが表示されま
す。

Applyを押します。
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Set Structured Index

成功するとこのようなダイアログが表示されます。

以前有効でなかったPropertyタブのBlockが利用可能になっていることから
も、格子点の配置が成功したことがわかります。

実際にModeをBlockにすると、どのように格子点が配置されたのかが分かりま
す。
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Edit Structured Index

4.13.2. Edit Structured Index

構造メッシュを編集する
構造メッシュに付加されたインデックスの向きを変更、
複数のブロックを統合する、ブロックをConformalに分
割する、ブロックを任意の位置で分割するなどの機能が
追加されています。

操作方法

1. 1.[メニューバー]→[Tools]→[Edit Structured Index]

2. 2. Edit Structure Index ウィンドウからタブを選択し各種編集操作をする

例4.73 Conformalな構造格子の接続

構造メッシュのブロックをひとつの四角形(2D)または六面体(3D)とみな
し、ブロック同士で四角形の辺(2D)または六面 体の面(3D)を共有すると
き、必ず過不足なしで２個のブロックで接続している場合をここでは
Conformal な接続と呼ぶことにします。

例えば図のような構造メッシュの各ブロックはConformal に接続してい
ます。
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Edit Structured Index

上のメッシュは黄色ブロックの一つの辺に対して二つのブロックが接続されて
います。

下のメッシュは青のブロックの一つの辺に 対して、もう一方の緑のブロックが
三つの辺で接続されています。

これらのようなブロックはConformal でない接続となります。
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Edit Structured Index

例4.74 Edit Structure Indexウィンドウ

Direction タブでは構造メッシュのインデックスの 向きを変更します。

上から、

• Block : 変更対象となるブロックID

• Exchange : インデックス同士を入れ替える

◦ I ⇔K : インデックスI とインデックスK を入れ替える

◦ J ⇔ K : インデックスJ とインデックスK を入れ替える

◦ I ⇔ J : インデックスI とインデックスJ を入れ替える

• Reverse :インデックスの始点、終点を反転させる

◦ I : インデックスI の始点、終点を反転させる

◦ J : インデックスJ の始点、終点を反転させる

◦ K : インデックスK の始点、終点を反転させる

• Adapt Other Blocks : 他のブロックにも変更を適用する

237



Edit Structured Index

Merge Block タブではConformalな接続をしているブロック同士をひとつのブ
ロックに統合します。

Blocks[+]でブロック選択ウィンドウを開くと、選択済みブロックリストが表
示される。

Split Block タブではブロックを複数のブロックに分割します。
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Edit Structured Index

• All Connection to Conformal : Conformal な状態へ自動分割する

• Single Block : 指定した位置で分割する

• Split with Number : ブロック数を指定して分割する

図はSplit Block タブでSingle Block を選択したときの状況です。

• All Connection to Conformal : 分割対象のブロック

• Single Block : 分割するインデックス方向

• Split with Number : 分割するインデックスの番号
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Edit Structured Index

図はSplit Block タブでSplit with Numberを選択したときの状況です。

• Number of Blocks : 分割後のブロック数

例4.75 構造メッシュのインデックスの向きを変更する

図の構造メッシュは2つのブロックからなる構造メッシュです
が、Inspection タブを利用するとI方向のインデックスの増加方向が揃っ
ていません。

これを揃えるためEdit Structured Index のDirection 機能を使用します。
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Edit Structured Index

メニューバーの Tools → Edit Structured Index を選択します。

Edit Structure Index ウィンドウが開くので、Direction タブを選択し、イン
デックスを入れ替えるブロックを選択し、ExchangeからI⇔Jを選びます。

現在編集対象のブロックはモデル画面でハイライトされ、その各インデックス
の増加方向が示されます。
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Edit Structured Index

Apply ボタンをクリックします。

Inspection タブでI インデックスの順を確認すると二つのブロックのIインデッ
クスの増加方向が揃ったことが確認できます。

例4.76 構造メッシュのブロックを統合する

図の構造メッシュのブロック1(黄)とブロック3(青)を統合して、ブロック
2(緑)との接続をConformal にします。
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Edit Structured Index

同様にメニューバーのTools → Edit Structured Indexを選択しウィンドウを開
いたら、Merge Block タブを選択して、Blocks ボタンをクリックします。

Selecting Blocks ウィンドウが開きブロックの一覧がリストに表示されるの
で、統合させたいブロックをリストから選びクリックし、選択状態にして、OK
ボタンをクリックします。

ここではブロック1 とブロック3を統合させるため、選択状態にしています。
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Edit Structured Index

Edit Structure Index ウィンドウの選択済みのブロックがリストに表示 される
ので、Apply ボタンで統合を実行します。

ブロック1 とブロック2 が統合されました。

1(黄)とブロック2(緑)など、Conformal でない接続をしているブロック同士を
統合しようとしても失敗します。
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Edit Structured Index

例4.77 構造メッシュのブロックをConformal に分割する

図のような非Conformal な接続を含んだ構造メッシュに対し て、全ての
接続がConformalになるようにブロックを分割します。

同様にメニューバーの Tools → Edit Structured Index を選択してウィンドウを
開いたら、Split Block タブを選択し、All Connection to Conformalを選択して
Applyボタンをクリックします。
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Edit Structured Index

ブロックが分割され、ブロック同士の接続が全てConformal になりました。

例4.78 構造メッシュのブロックをインデックスで指定して分割する

ブロックとそのブロック内の構造メッシュのインデックスを指定するこ
とによってブロックを任意のインデックスで分割します。

ここでは図のような単一ブロックの 構造メッシュを矩形部と扇状部に分
割します。
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Edit Structured Index

同様に、メニューバーの Tools→ Edit Structured Indexを選択してウィンドウ
を開いたら、Split Blockタブを選択し、Single Blockを選択して、さらに対象
Block インデックス方向と位置を選択します。

メッシュ画面には分割されることになる境界線が表示されます。図ではI 方向
に8 番目のインデックスで分割する設定になっているため、メッシュ画面でも
そのように表示されています。

Apply ボタンをクリックします。
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Edit Structured Index

Block が指定したインデックスで分割されて２つのBlock になりました。

例4.79 構造メッシュのブロックをブロック数で指定して分割する

ブロック数を指定して分割します。
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Edit Structured Index

同様にメニューバーのTools→ Edit Structured Index を選択してウィンドウを
開いたら、Split Block タブを選択し、 Split with Numberを選択して、さらに
分割後のBlock 数 を設定します。

設定し終えたらApply ボタンを クリックします。

Block 数を3 に設定していたため3 つのBlock に分割されました。
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Set Structured Boundary

4.13.3. Set Structured Boundary

構造メッシュ用の境界面名を自動設定する
MeshメニューのStructuredに対し、煩雑な境界面の設定
を省くために、境界面の名前を自動で変更します。この
操作は現在のメッシュが2Dのときのみ有効です。

操作方法

1. [メニューバー]→[Tools]→[Set Structured Boundary]

2. 各種設定をしてOKボタンをクリック

3. 境界面の分割候補が複数ある場合、Nextボタンで選びApplyボタンで適用

例4.80 境界面を構造メッシュ向けに設定して構造メッシュに再分割する

図のような境界面が複数あり、2D構造メッシュを作る際のI,Jインデック
スの高低方向を設定する作業が煩雑となる2Dメッシュの境界面振り分け
を半自動的に設定します。
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Set Structured Boundary

メニューバーのTools→Set Structured Boundaryを選択します。

以下の設定項目をチェックします。

• Feature Angle : 境界面を区切る面の角度<

• Adjacent Side Coefficient : 隣接する境界面の総延長比の効果

• Opposite Side Coefficient : 対面となる境界面の総延長比の効果

• Angle Coefficient : 境界面同士の接する角度の効果

今回は特に設定を変更せずに、OKボタンをクリックします。

境界面が4つに再分割され、MeshメニューのStructured で自動的に境界面が振
り分けられるゾーン名に変更されました。

このメッシュを試しに構造メッシュに再分割してみます。
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Set Structured Boundary

メニューバーのMesh→Structured…をクリックします。

構造メッシュ再分割の設定タブが開きます。

本来はインデックスi,jが最大、最小になる境界面を振り分ける必要があります
が、これまでの手順で変更された境界面名で自動的に振り分けられるので、こ
この設定は省略できます。

分割数を適当に設定してApplyボタンを押します。

インデックスの高低を手動で振り分けることなく、構造メッシュに再分割でき
ました。
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Set High-Order Elements

4.13.4. Set High-Order Elements

高次要素を追加する
EditメニューのSubdivideでメッシュを2分割した履歴を
使って現在のメッシュの縦・横・奥行2列ずつ、計8個組
の六面体セルを1個の二次要素付きの六面体セルとして扱
うように変換します。

この操作は直前にEditメニューのSubdivide機能を使って
六面体セルでのみ構成されるメッシュを2分割したときの
み可能です。

Convertメニューの1st to 2nd Orderと異なる点は六面体
でのみ可能な事です。またセルの辺の中点のみではな
く、セル面の中心やセル内部にも二次要素の節点が存在
します。

操作方法

1. [メニューバー]→[Edit]→[Subdivide]でメッシュを2分割する

2. [メニューバー]→[Tools]→[Set High-Order Elements]

例4.81 メッシュを2分割して高次要素付きセルにまとめる

図のような六面体セルでのみ構成されているようなメッシュに高次要素
を追加します。
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Set High-Order Elements

下準備としてメッシュを2分割します。

メニューバーのEditメニューからSubdivideを実行します。

分割数を2（デフォルト値）に指定して実行ボタンをクリックします。

チェックボックスをオンにすることで任意にスムージングをかけてセルを滑ら
かに膨らましたり凹ませたりできます。

スムージング分割に関してはEditメニューのSubdivideの項目を参照してくだ
さい。
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Set High-Order Elements

メッシュが2分割され、履歴に分割前のメッシュが登録されました。

メニューバーのTools → Set High Order Elements で8個のセルをひとつの高次
要素付きセルにまとめます。

高次要素付きセルにまとめることに成功しました。

失敗する場合は、

・六面体以外のセルが含まれていた

・直前の履歴が2分割前のメッシュになっていない

などの原因が考えられます。

InspectionタブのShrinkでセルを縮小すると、8個の六面体が1個のセルとして
扱われていることがわかります。
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Set High-Order Elements

またInspectionのVariableやメニューバーのReportメニューからJacobian関連
の項目が有効になります。
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Unset High-Order Elements

4.13.5. Unset High-Order Elements

高次要素を解除する
前項でセットした二次要素や、元から同様の二次要素を
含むメッシュを読み込んだ場合の二次要素を解除し、そ
れぞれの六面体を1個のセルとして扱うようにします。

操作方法

1. [メニューバー]→[Tools]→[Set High-Order Elements]

前項まででSet High-Order Elementsで二次要素を追加したメッシュです。プ
ロパティタブのShrink機能を使うと8個1組の六面体が1個のセルとして扱われ
ています。

これを解除します。

メニューバーの Tools→ Unset High-Order Elementsを選択します。
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Unset High-Order Elements

二次要素の解除の完了を知らせるダイアログを閉じると、図のように8個1組
だった六面体がばらけて、1個ずつセルとして扱われるようになりました。
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Correct Face Normal

4.13.6. Correct Face Normal

面の法線を修正する
メッシュファイルを読み込んだとき面の表裏が逆転して
いる場合にそのようなメッシュを検出し、法線方向が外
向きになるように修正します。

操作方法

1. [メニューバー]→[Tools]→[Correct Face Normal]

メッシュファイルの問題などで、フェイスの法線ベクトルの向きがメッシュの
外側を向いていない場合があります。この機能はそのようなフェイスを検出
し、法線ベクトルの向きを外向きに修正します。

今回の例ではこのメッシュを使います。

手前側と奥側の両方に光源がある場合は、表示にそれほど違和感がありません
が、どちらか片方のみにした場合、このように表示がおかしくなることから、
法線の異常がわかりやすくなります。
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Correct Face Normal

また、Insideモードで表示することで、メッシュの内側の様子から異常を目視
できます。

このようなフェイスを修正するには、Correct Face Normalをクリックします。

修正されるフェイスの数が表示されます。 OKボタンで修正します。
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Correct Face Normal

修正後のInsideモードでの表示です。目視上の異常もなくなっています。

光源を片方向にしても異常部分はありません。

全てのフェイスの法線ベクトルが、外側を向いていることが分かります。
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Unite All Cell Zones

4.13.7. Unite All Cell Zones

全てのセルゾーンをマージする
全てのセルゾーンをマージしてfluidという単一のセル
ゾーンのみにします。

操作方法

1. [メニューバー]→[Tools]→[Unite All Cell Zones]

まず、分かりやすさの為に[Cells]をチェックしてセルゾーンのリストを表示し
ます。

この段階では3つのセルゾーンがあります。

メニューバーの Tools →Unite All Cell Zonesを選択します。

変換後です。 セルゾーンが一つになっています。
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Set Default Surface Name

4.13.8. Set Default Surface Name

境界面の名前を自動設定する
境界面(Surface Zone)はそれぞれに、wall / pressure-
inlet / pressure-outlet / symmetry / velocity-
inlet / mass-flow-inlet / interface / outflow /
axis のいずれかの境界タイプが設定されています。この
機能は境界面の名前を、このタイプを基にしたものに自
動的に設定します。

操作方法

1. [メニューバー]→[Tools]→[Set Default Surface Name]

Surface Zoneの名前をデフォルトのものに直します。

メニューバーの Tools→Set Default Surface Nameを選択します。

フェイスゾーンの名前が変更されました。
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Elastic Morphing

4.13.9. Elastic Morphing

メッシュを弾性変形する
境界面を指定することでメッシュの一部を弾性的に変形
させることができます。変形方法は移動、回転、拡大縮
小があります。

操作方法

1. [メニューバー]→[Tools]→[Elastic Morphing]

2. 変形する箇所、固定される箇所、スライドする箇所を設定

3. 変形方法、パラメータを設定

4. Executeボタンをクリック

例4.82 メッシュの移動変形

Elastic Morphing（旧名Mesh Morphing）ではメッシュの一部の移動、
回転、拡大縮小が可能です。
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Elastic Morphing

図のようなダイアログが表示されます。

Steadyで指定された面は、この変形によって変わることはありません。

Slidingで指定された面は、この変形によって、周りの移動を補完するようにそ
の面上を移動します。

Movingで指定された面は、この指定された変形が適用されます。

いずれにも当てはまらない面は、周りの移動を補完するように、自由に空間上
を移動します。

それぞれの面を設定するにはSteady、 Sliding、 Movingの右にある+ボタンを
クリックして対象の面を選択します。
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Elastic Morphing

右上のTypeから、変形の種類を切り替えることが出来ます。

Translationは移動、Rotationは回転、Scalingは拡大縮小を示しています。
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Elastic Morphing

例としてTranslationで図のように指定します。

ここでは境界面a1と境界面a2の節点は動かさず、b1とb2の節点は自身の境界
面内を動き、c内の節点は(1.0, 0.0)の方向に距離1ぶん動きます。

変形後は図のようになります。

Steadyに属したa1、a2の節点は変化せず、Slidingに属したb1、b2の節点は境
界面に沿って移動し、Movingに属したcは、X軸方向に強制変位されました。
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Elastic Morphing

例4.83 メッシュの回転変形

図のようにTypeをRotationに設定すると、a1とa2とb1とb2は固定さ
れ、cは自身の重心を中心として反時計方向に回転します。

回転の大きさはAngleで設定し、例図の状態では30度回転します。

変形後は図のようになります。 Steadyに属したa1～b2の境界面上の節点は変
化せず、Movingに属したcは反時計回りに強制変位をうけました。
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Elastic Morphing

例4.84 メッシュの拡大縮小変形

図のようにTypeをScalingに設定すると、a1とa2とb1とb2は固定さ
れ、cは重心位置を中心として拡大縮小されます。

倍率はScaling ratioで設定し、例図の状態では0.5倍に縮小されます。

変形後は図のようになります。

Steadyに属した a1～b2の境界面上の節点は変化せず、Movingに属したcは強
制変位をうけ、縮小されました。
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Elastic Morphing
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Interpolation Morphing

4.13.10. Interpolation Morphing

メッシュの境界変形を補完して変形する
境界面を指定して移動することでメッシュを変形させま
す。

操作方法

1. [メニューバー]→[Tools]→[Interpolation Morphing]

2. 移動変形するゾーンを指定

3. 指定されなかったゾーンの取り扱い方法を指定

4. 移動方向ベクトルの指定やその他のパラメータを設定

5. Applyボタンをクリック
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Interpolation Morphing

例4.85 ウィンドウ各部位

• Moving Boundary: 選択された移動面

• Fix Mode/Slide Mode: 選択されなかった面の扱い

• Fix Boundary Margin: 固定面と一緒に固定される点への距離(Fixモー
ド)

• Sliding Boundary Margin: 固定面と一緒に固定される点への距離(Slide
モード)

• Moving Boundary Margin: 移動面と一緒に移動する点への距離

• Effectable Length: Slide対象となる移動面からの距離(Slideモード)

• Outline Effectable Length: 移動距離が均等配分される移動-固定境界
からの距離

• Feature Angle: Slidingの拘束を二方向にする特徴線となる面同士の角
度

• Step Division: 移動の分割実行数
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Interpolation Morphing

例4.86 変形させるモデル

使用例で使用するメッシュについて簡単に説明します。

このデータは立方体の中心に球形の空洞があり、その空洞と外部が細い
ダクトでつながっている構造をしています。

アイコンバーのInsideを有効にしてメッシュの内部を見れるようにすると内側
に隠れていた境界面が見えます。

例4.87 Fixモード

これから中心の球とダクトを移動させ、内部点も補完して動かします。
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Interpolation Morphing
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Interpolation Morphing

メニューバーから「Tools」→「Interpolation Morphing」を選択しクリックし
ます。

これから移動する境界面を選択します。

Selectボタンをクリックします。
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Interpolation Morphing
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Interpolation Morphing

境界面ゾーンの選択ウィンドウが表示されるので、移動しうる境界面を指定し
ます。指定しなかったゾーン上の節点は固定点になります。

ここでは「core」と「duct」を選択し移動対象とし、「wall」は固定対象とし
ました。

Applyボタンをクリックします。

動かす方向と大きさをMoving Vectorで設定します。 ここではX軸平行方向に
1.5動かすことにします。

中心にあった球殻が右に移動しました。
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Interpolation Morphing

図4.1 移動前

図4.2 移動後

Inspectionで内部セルを観察しても移動した境界面と固定面の間を補間するよ
うに内部点が動いていることが示されます。
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Interpolation Morphing

例4.88 境界マージンの効果

固定面付近の内部点は移動面にひきずられ移動し、移動面付近の内部点
は固定面に引っ張られて移動が遅れるため、境界層を持つメッシュの場
合、移動後の境界層の直交性が保てない場合があります。
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Interpolation Morphing

Fixed Boundary Marginは固定面からその距離内にある内部点も一緒に固定
し、Moving Boundary Marginは移動面からその距離内にある内部点も同じ距離
を移動させるようにします。

Fixed Boundary MarginやMoving Boundary Marginを広げて境界層がその範囲
に入るようにしたことで、直交性を保った移動変形ができます。
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Interpolation Morphing

例4.89 Outline Effectable Lengthの効果

その他の設定値をデフォルトのままX方向に+1.5移動させると、移動面
ductと固定面wallの境界付近で不均一に詰まり、これ以上移動させると
境界の隣にある節点が外に飛び出します。
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Interpolation Morphing

Outline Effectable Lengthは移動面上の各節点と固定面-移動面境界線からの
距離のうち最大値として与えられ、その範囲内にある移動面上の点は均等に移
動するように調整されます。

この例ではductとwallの境界線から距離10以内にあるductおよびwall上の節点
が均等に移動するように調整されました。

例4.90 Slideモード

Slide Modeに切り替えるとEffectable Lengthが有効になります。

移動面からEffectable Lengthの距離内にある固定面上の点は面の法線方
向を拘束された移動が可能になり、固定面上をスライドするようになり
ます。
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Interpolation Morphing

図4.3 移動前

図4.4 Fixモード

図4.5 Slideモード, Effectable Length=30

Slideモードにした影響で球核奥側のwallも移動面から30以内の点ならばスラ
イド移動している様子がみられます。
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Slit Surface

4.13.11. Slit Surface

表面メッシュを切り分ける
数値で指定した平面が通過した交線に沿って、表面メッ
シュの境界面に接点や辺を追加します。

操作方法

1. [メニューバー]→[Tools]→[Slit Surface]

2. 断面となる平面のパラメータを設定

3. Applyをクリック

Slit Surface は指定した断面との交線がメッシュの辺となるように、 表面メッ
シュを切断する機能です。

この例ではInspection 等の他の機能を併用して、左図のような X=2 に対称な
表面メッシュを対称面で切り、X≧2 の部分のみを 残す操作をします。

指定した平面でSurface のみのメッシュを分割します。

メニューバーのTools→ Slit Surface…を選択します。
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Slit Surface

断面となる平面の法線方向と、原点からの距離 で断面を指定します。

また交点、交線の閾値を調整し、Apply ボタンをクリ ックして切断を実行しま
す。

Surface メッシュが平面X=2 との交線で切断されました。

Cancel ボタンでSlit Surface ウィンドウを閉じます。

Inspection タブを用いて表示部分と非表示部分を分けます。 Inspection タブ
をクリックし、Coordinate タブの Xを選択します。そしてPosition のテキスト
ボックス に2.0 を入力します。

これで図のようにX≧2 の部分を表示、X＜2 の部分を非表示に 分けられまし
た。
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Slit Surface

メニューバーのEdit→ Delete Invisible で非表示になっている、X＜2 の部分を
消去します。

X≧2 の部分のメッシュが残ります。
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2D →　3D

4.13.12. 2D →　3D

2 次元のメッシュを3 次元のメッシュとみな
す

2 次元のメッシュを3 次元のメッシュとみなし、3 次元
メッシュにのみ適用される操作を有効にします。Convert
メニューの2D to 3D 機能におけるデフォルト状態の挙動
と結果上の差異はありませんが、こちらはより高速に変
換されます。

操作方法

1. [メニューバー]→[Tools]→[2D → 3D]

メニューバーのTools→2D→3D を選択します。

３次元のメッシュにした様子です。
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Clear Undo History

4.13.13. Clear Undo History

変更履歴の破棄
QuickMesh では起動時から終了時までUndo機能の実現の
ために、変更内容を記録しています。 Undo 機能を使うつ
もりが無ければ、これまでの変更履歴を破棄してメモリ
の節約ができます。

操作方法

1. [メニューバー]→[Tools]→[Clear Undo History]

メニューバーのTools→ Clear Undo History を選択します。
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Save Pictures

4.13.14. Save Pictures

まとめてメッシュの画像を保存する
指定したフォルダ内にあるメッシュを読み込み、その外
観の画像ファイルを同フォルダに保存します。

操作方法

1. [メニューバー]→[Tools]→[Save Pictures]

2. 保存対象のフォルダを選択

3. メッシュそれぞれに読み込み形式を指定する

メニューバーのTools→ Save Pictures を選択します。

フォルダ選択ダイアログが表示されるので、読み込みたいフォルダを 選択しま
す。

この読み込みについてはLoadFiles と変わったところはありません。

289



Save Pictures

今回例として、選択したmesh_files フォルダはこのようになっています。

それぞれについてファイル形式が曖昧な場合、Open 機能と同様のダ イアログ
が表示されるので、形式を選択してOK ボタンを押します。

一つめのメッシュが読み込まれ、そのキャプチャ画像が自動的に同フ ォルダに
保存されました。

以降、メッシュごとにダイアログが繰り返し表示されます。
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Save Pictures

全てのファイルが読み込まれてダイアログが表示されなくなり、画像の 書き出
しが完了しました。

先ほどのフォルダを見ると、ファイルごとに画像が出力されているのが分 かり
ます。
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Load Files

4.13.15. Load Files

まとめてメッシュを読み込む
指定したフォルダ内にあるメッシュを全て読み込
み、Undoの履歴に登録します。

操作方法

1. [メニューバー]→[Tools]→[Load Files]

2. 読み込み対象のフォルダを選択

3. メッシュそれぞれに読み込み形式を指定する

メニューバーのTools→ Load Files を選択します。

フォルダ選択ダイアログが表示されるので、読み込みたいフォルダを選択しま
す。
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Load Files

今回例として読み込んだフォルダは、このようになっています。

読み込み対象ファイルの中に、フォーマットが曖昧な場合があれば、通常の読
み込みと同様に、読み込み形式を指定するダイアログが表示されます。

フォルダ内のメッシュファイルの読み 込みが終わりました。 読み込まれたメッ
シュデータがヒストリに登録されています。
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Load Files

Undo/Redo で、ヒストリに登録されていることが分かります。
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Playback History

4.13.16. Playback History

変更履歴を連続再生する
Undo に登録された、これまでのメッシュの変更履歴を順
番に表示します。

操作方法

1. [メニューバー]→[Tools]→[Playback History]

2. Playback のウィンドウを操作し、変更を確認する

メニューバーのTools→ Load Files を選択します。

Tools メニューのPlayback Historyを押すと、上のようなダイアログが表示さ
れます。

左から、

• 再生を一時停止します。

• 過去から未来の方向で再生を開始します。

• 往復するように再生を開始します。つまり、はじめは未来から過去の方向に
再生し、最も古い変更に到達すると、今度は過去から未来の方向に再生しま
す。

• 未来から過去の方向で再生を開始します。

• 再生するスピードを変更します。左のほうが早く、右のほうが遅くなりま
す。
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Playback History

• 最新の変更からいくつ分までを再生するのか設定します。0の時は、特別に
全ての変更を再生します。
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Update License

4.13.17. Update License

ライセンスを更新する
ライセンスファイルを読み込んで、QuickMeshのライセ
ンスを更新します。この操作は、QuickMeshを管理者権
限で起動している時のみ利用できます。

操作方法

1. QuickMesh を管理者権限で起動

2. [メニューバー]→[Tools]→[Update License]

3. Update ボタンをクリック

4. ライセンスファイルを選択

メニューバーのTools→ Load Files を選択します。

確認ダイアログが表示されます。Update ボタンをクリックするとファイ ル選
択ダイアログが表示されるので、新しいライセンスファイルを選択 します。
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Update License

何らかの理由でライセンスファイルを読み込めなかった場合、このよ うなダイ
アログが表示されます。

無効なファイルが読み込まれた時、このようなダイアログが表示さ れます。

ライセンスの認証に成功した時、このようなダイアログが表示されます。
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Settingsメニュー

4.14. Settingsメニュー

4.14.1. Tessellation Option

CADファイルのメッシュ表示・変換を設定
する

QuickMeshで対応するCADファイルを読み込んだ場合、
境界表現で記述されたモデルを三角形のポリゴンで表現
された表面メッシュに分割して表示し、メッシュ形式に
変換するときも、その分割メッシュを利用することにな
ります。 その分割の際のパラメータをこの機能で設定
し、読み込んだCADデータを再分割します。

操作方法

1. 対応するCAD形式のファイルを読み込む

2. [メニューバー]→[Setting]→[Tessellation Option]

3. 値を調整する

4. Applyボタンをクリック
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Tessellation Option

例4.91 Tessellation Option ウィンドウ

• length Deflection

◦ Relative : 距離偏差を相対値とする

◦ Absolute : 距離偏差を絶対値とする

◦ Deflection Length : 距離偏差

• Angular Deflection : 角度偏差(度数)

• Reset : 初期値に戻す

例4.92 各パラメータの意味

距離偏差は、元の境界表現の曲面と分割後の三角形面 との距離を制限す
ることで、分割の細かさをコントロールする パラメータです。

数値の意味をメッシュの長さスケールに対する割合 (relative)と、座標間
の距離(absolute)で変更することができます。

300



Tessellation Option

角度偏差は、分割後の隣接する頂点の接面同士の角度を制限することで、分割
の細かさをコントロールするパラメータです。

有効な値の範囲は0 度より大きく、90 度以下です。90 度以上の値が入力され
た場合は、90 度として扱われます。

例4.93 読み込んだCAD ファイルを再分割する

読み込んだCAD 形式のモデルのメッシュが粗かったため、再分割しま
す。

CAD 形式のファイルを読み込んだあとに、メニューバーのSetting→
Tessellation Option…を選択します。
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Tessellation Option

Deflection Length 、またはAngular Deflection の値を小さくすることでメッ
シュを細かくできます。

ここではDeflection Lengthをデフォルト値の0.01 から0.001 に変更しまし
た。 Apply ボタンをクリックします。

メッシュが再分割され、表面メッシュによる曲面の再現の精度が 上がりまし
た。
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Feature Angle

4.14.2. Feature Angle

Feature線判定の閾値を変更する
アイコンバーなどからFeature線を表示する際
に、QuickMeshでは表面のフェイス同士の角度を比較
し、一定角度よりも鋭く折れ曲がっているとき
に、Feature線として判別しています。その際の閾値とな
る角度をここで設定します。

この機能はFeature線が表示されている状態のときに使用
できます。

操作方法

1. [アイコンバー]→FeatureボタンでFeature線を表示

2. [メニューバー]→[Settings]→[Feature Angle]

3. 閾値角度を変更してApplyボタンをクリック

4. Closeボタンを押して閉じる

アイコンバーのFeatureボタンからFeature線表示を有効にし、メニューバーの
Setting→Feature Angleを選択します。
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Light Position

フェイス間の折り目と見做される角度を設定 します。度数法で値を入力
し、Apply をクリックすると反映されます。

4.14.3. Light Position

立体表現用の光源の位置を変更する
3Dメッシュ表示時には、そのモデルの立体感を表現する
ために、表面に陰影がつけられています。その陰影計算
の基になる平行光源の位置をここで設定できます。

操作方法

1. [メニューバー]→[Settings]→[Light Position]

2. 光源位置を設定しApplyボタンを押す

3. Closeボタンを押して閉じる

メニューバーのSetting → Light Positionを選択し、光源の位置を変更しま
す。

原点から見て光源がある方向ベクトルを入力します。 Apply をクリックすると
変更が反映されます。 ここではx値を増やしたために、ゾーン"outflow-2"がよ
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Perspective Level

り明るくなり、相対的に小さくなった成分方向に向いた面は暗くなっていま
す。

4.14.4. Perspective Level

透視投影用の遠近感を変更する
アイコンバーなどから遠近感を表現した透視投影を有効
にした際、その遠近感の強さを3段階で調整します。

この機能は、透視投影でモデルを表示しているときに使
用できます。

操作方法

1. [アイコンバー]→Persボタンで透視投影に切り替え

2. [メニューバー]→[Settings]→[Perspective Level]

3. ラジオボタンを切り替えて変更

4. Closeボタンで閉じる

メニューバーのSetting → Perspective Levelを選択すると、遠近法の強さを設
定できます。
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Point Size

ラジオボタンを切り替えると変更が適用され、遠近感が変化します。 ここでは
Nearに変更して遠近感を強くしています。

4.14.5. Point Size

Node描画時の描画サイズを変更する
アイコンバーなどから、ノードを強調表示した際の描画
サイズをここで設定します。

操作方法

1. [アイコンバー]→NodeボタンでNodeを表示する

2. [メニューバー]→[Settings]→[Point Size]

3. 数値を変更

4. Closeボタンで閉じる

Point Size では表示するNodeの大きさを設定します。ここでは変化がわかり
やすいように、アイコンバーのNodeをONにしてNodeを描画しています。 メ
ニューバーから「Setting」→「Point Size」で、図のようなウィンドウを表示
させます。
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Decimal Places

値を変更すると、Node が表示される大きさが変わります。

4.14.6. Decimal Places

表示桁数を変更する
Decimal Places ではモデルビュー画面などで数値を表示
する際、その表示桁数を設定できます。

操作方法

1. [メニューバー]→[Settings]→[Decimal Places]

2. 数値を変更する

3. Closeボタンでウィンドウを閉じる

Decimal Places で数値の表示桁数を設定します。

ここでは変化をわかりやすくするため、コンテキストメニューのNode Indexか
らNodeの座標値を表示しています。

値を変更すると同時に、表示されている桁数が変化します。
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Bounding Box

4.14.7. Bounding Box

Bounding Boxの表示内容を変更する
SettingメニューにおけるBounding Boxは、コンテキスト
メニューやViewメニューなどから表示できるバウンディ
ングボックスの表示内容を設定します。

この機能はBounding Box 表示時にのみ使用できます。

操作方法

1. コンテキストメニューからBounding Boxを表示する

2. [メニューバー]→[Setting]→[Bounding Box]を選択

3. 表示/非表示にしたいものをチェックボックスから切り替える

4. Closeボタンで閉じる

Bounding Box ではメッシュの範囲の表示を設定できます。

• coordinate : Bounding Box の座標の表示/非表示を設定できます。

• Size : Bounding Box の大きさの表示/非表示を設定できます。
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Rotation Center

4.14.8. Rotation Center

視点の回転中心を変更する
QuickMeshでは視点をマウスで回転させたとき、その回
転中心は表示されているモデルの境界面に自動で決定さ
れます。Rotation Centerでは、その回転中心が境界面上
にあるNodeにするかFaceにするかを設定します。

操作方法

1. [メニューバー]→[Settings]→[Rotation Center]

Rotation Center では視点の回転中心を設定できます。

• Node Base : Node をもとに回転中心を計算します。

• Face Base : Face をもとに回転中心を計算します。

4.14.9. Color Mode

表示色セットを変更する
境界面を表示する際の配色を、3つあるプリセットのどれ
か一つに変更します。

操作方法

1. [メニューバー]→[Settings]→[Color Mode]

2. 3つのプリセットのどれかひとつを選択

3. Closeボタンで閉じる
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Background Color

Color Mode ではゾーンに割り当てる色の選び方を設定できます。

Middle を選ぶとこのようになります。

Deep を選ぶとこのようになります。

4.14.10. Background Color

背景色を変更する
Background Colorではモデル表示画面の背景色を任意の
変更します。変更できます

操作方法

1. [メニューバー]→[Settings]→[Background Color]

310



Undo Levels

2. 色を選択する

3. OKボタンで背景色を決定

4.14.11. Undo Levels

Undo履歴の数を設定する
QuickMeshのメッシュのUndo履歴は、デフォルト状態で
10ですが、Undo Levelsでメッシュの履歴の最大数を変
更できます。

操作方法

1. [メニューバー]→[Settings]→[Undo Levels]

2. 保持可能な最大履歴数を変更する

3. Applyボタンで変更を適用する
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Windowメニュー

4.15. Windowメニュー

4.15.1. Full Screen

フルスクリーン表示する
QuickMeshを画面全体に表示します。

操作方法

1. [メニューバー]→[Window]→[Full Screen]で画面全体に表示

2. 再度 [メニューバー]→[Window]→[Full Screen]で元のウィンドウサイズに
戻す

4.15.2. Resize

ウィンドウサイズを数値指定して変更する
QuickMeshのウィンドウサイズを縦横幅を指定して変更
します。この機能を利用して表示したモデルの外観を画
像ファイルとして保存するときの再現性を向上させま
す。

操作方法

1. [メニューバー]→[Window]→[Resize]

2. 横長、縦長を入力してOKボタンを押す。

4.15.3. Hide Tab

メインタブを非表示にする
QuickMeshの画面右側にあるメインタブの非表示/表示を
ここで切り替えられます。

操作方法

1. [メニューバー]→[Window]→[Hide Tab]をONにしてメインタブを非表示
にする

2. [メニューバー]→[Window]→[Hide Tab]をOFFにしてメインタブを表示す
る
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Hide Tab
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Helpメニュー

4.16. Helpメニュー

4.16.1. About

概要を表示する
使用中のQuickMeshのバージョン情報や著作権などを表
示します。

操作方法

1. [メニューバー]→[Help]→[About]

2. OKボタンでダイアログを閉じる

Aboutではソフトウェアのバージョンや著作権表示、ビルド情報を表示しま
す。

4.16.2. Open Source License

使用しているフリーソフトウェアライセン
スを表示する

QuickMesh内で使用しているライブラリのライセンスに
ついて表示します。

操作方法

1. [メニューバー]→[Help]→[Open Source License]

2. Closeボタンでダイアログを閉じる
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Open Source License

Open Source Licenseで使用したライブラリのライセンスが表示されます。
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5
対応ファイル形式一覧

5.1. 拡張子と対応ﾌｫｰﾏｯﾄ

表5.1 流体解析

フォーマット

テキスト バイナリ FORTRAN
アンフォー
マット

ファイルの種類 ファイル拡張子

読み
込み

書き
込み

読み
込み

書き
込み

読み
込み

書き
込み

Flient Mesh/Ca
se

msh ,cas ✔ ✔ ✔ ✔ - -

STAR-CD V4 vrt, cell, bnd, inp ✔ ✔     - -

CFX Grid grd ✔ ✔ ✔ ✔ - -

CRUNCH CFD
Mesh

precrunch ✔ ✔ ✔ ✔ - -

OpenFOAM
PolyMesh

polyMesh(directory)✔ ✔ ✔   - -

SU2 Mesh su2 ✔ ✔ - - - -

FaSTAR Grid fsgrid - - - - ✔ ✔

LS-FLOW Grid apg - - - - ✔ ✔

PLOT3D dat, xyz, grd,
p3d, p2d, x, g

✔ ✔ ✔   ✔ -
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拡張子と対応ﾌｫｰﾏｯﾄ

CGNS cgns ✔ ✔ ✔ ✔ ✔ ✔
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拡張子と対応ﾌｫｰﾏｯﾄ

表5.2 構造解析

フォーマット

テキスト バイナリ FORTRAN
アンフォー
マット

ファイルの種類 ファイル拡張子

読み
込み

書き
込み

読み
込み

書き
込み

読み
込み

書き
込み

NASTRAN Bulk
Date

dat,nas,bdf ✔ ✔ - - - -

ABAQUS Input inp, abq ✔ ✔ - - - -

ANSYS Input inp, cdb, dat ✔ ✔ - - - -

Marc Input dat ✔ ✔ - - - -

LS-DYNA Input k ✔ ✔ - - - -

ADVENTURE
Mesh

msh, pch, pcm ✔ ✔ - - - -
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拡張子と対応ﾌｫｰﾏｯﾄ

表5.3 プリポスト

フォーマット

テキスト バイナリ FORTRAN
アンフォー
マット

ファイルの種類 ファイル拡張子

読み
込み

書き
込み

読み
込み

書き
込み

読み
込み

書き
込み

Tecplot plt, dat ✔ ✔ ✔   - -

EnSight Gold case, geo ✔ ✔ ✔ ✔ ✔ ✔

FieldView
Unstructured

      ✔ ✔ ✔ ✔

I-deas Universal unv ✔ ✔ - - - -

AVS
Unstructured

ucd ✔ ✔ - - - -

Visualization
Too lkit Input

vtk ✔ ✔ ✔ ✔ - -

Gambit Neutral neu ✔ ✔ - - - -

Gmsh msh ✔ ✔ - - - -

Medit Mesh mesh ✔ ✔     - -
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拡張子と対応ﾌｫｰﾏｯﾄ

表5.4 ポリゴンモデル

フォーマット

テキスト バイナリ FORTRAN
アンフォー
マット

ファイルの種類 ファイル拡張子

読み
込み

書き
込み

読み
込み

書き
込み

読み
込み

書き
込み

STL stl ✔ ✔ ✔ ✔ - -

3ds Max 3ds, max - - ✔ ✔ - -

Wavefront OBJ obj ✔ ✔ - - - -

GNU
Triangulated
Surface

gst ✔ ✔ - - - -

Stanford
Polygon

ply ✔ ✔ ✔ ✔ - -

Object File
Format

off ✔ ✔ - - - -

AutoCAD 3D
Face

dxf ✔ ✔ - - - -
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メッシュタイプ

5.2. メッシュタイプ

表5.5 流体解析

メッシュタイプ

構造格子

ファイルの種類

２次元 ３次元 体積要
素/セ
ル

表面
フェイ
ス

シン
グルブ
ロック

マルチ
ブロッ
ク

Flient Mesh/Case ✔ ✔ ✔ ✔ - -

STAR-CD V4 - ✔ ✔ - - -

CFX Grid - ✔ ✔ - - -

CRUNCH CFD Mesh - ✔ ✔ - - -

OpenFOAM PolyMesh - ✔ ✔ - - -

SU2 Mesh ✔ ✔ ✔ - - -

FaSTAR Grid - ✔ ✔ - - -

LS-FLOW Grid - ✔ ✔ - - -

PLOT3D ✔ ✔ ✔ - ✔ ✔

CGNS - ✔ ✔ - ✔ ✔
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メッシュタイプ

表5.6 構造解析

メッシュタイプ

構造格子

ファイルの種類

２次元 ３次元 体積要
素/セ
ル

表面
フェイ
ス

シン
グルブ
ロック

マルチ
ブロッ
ク

NASTRAN Bulk Date - ✔ ✔ ✔ - -

ABAQUS Input ✔ ✔ ✔ ✔ - -

ANSYS Input - ✔ ✔ ✔ - -

Marc Input - ✔ ✔   - -

LS-DYNA Input - ✔ ✔ ✔ - -

ADVENTURE Mesh - ✔ ✔ - - -
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メッシュタイプ

表5.7 プリポスト

メッシュタイプ

構造格子

ファイルの種類

２次元 ３次元 体積要
素/セ
ル

表面
フェイ
ス

シン
グルブ
ロック

マルチ
ブロッ
ク

Tecplot - ✔ ✔ ✔ ✔ ✔

EnSight Gold - ✔ ✔ ✔ ✔ ✔

FieldView
Unstructured

- - ✔ ✔ ✔ -

I-deas Universal - ✔ ✔ ✔ - -

AVS Unstructured - ✔ ✔ ✔ - -

Visualization Toolkit
Input

- ✔ ✔ ✔ - -

Gambit Neutral - ✔ ✔ ✔ - -

Gmsh - ✔ ✔ ✔ - -

Medit Mesh - ✔ ✔   - -
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メッシュタイプ

表5.8 ポリゴンモデル

メッシュタイプ

構造格子

ファイルの種類

２次元 ３次元 体積要
素/セ
ル

表面
フェイ
ス

シン
グルブ
ロック

マルチ
ブロッ
ク

STL - ✔ - ✔ - -

3ds Max - ✔ - ✔ - -

Wavefront OBJ - ✔ - ✔ - -

GNU Triangulated
Surface

- ✔ - ✔ - -

Stanford Polygon - ✔ - ✔ - -

Object File Format - ✔ - ✔ - -

AutoCAD 3D Face - ✔ - ✔ - -
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体積要素の種類

5.3. 体積要素の種類

表5.9 流体解析

体積要素の種類

四面体 プリズム ピラミッ
ド

六面体

ファイルの種
類

4節
点

8節
点

6節
点

15
節
点

5節
点

8節
点

8節
点

20
節
点

27
節
点

ハ
イ
ブ
リッ
ド

任
意
多
面
体

Flient Mesh/
Case

✔ - ✔ - ✔ - ✔ - - ✔ ✔

STAR-CD V4 ✔ - ✔ - ✔ - ✔ - - ✔ ✔

CFX Grid ✔ - ✔ - ✔ - ✔ - - ✔ -

CRUNCH CFD
Mesh

✔ - ✔ - ✔ - ✔ - - ✔ -

OpenFOAM
PolyMesh

✔ - ✔ - ✔ - ✔ - - ✔ ✔

SU2 Mesh ✔ - ✔ - ✔ - ✔ - - ✔ -

FaSTAR Grid ✔ - ✔ - ✔ - ✔ - - ✔ -

LS-FLOW Grid ✔ - ✔ - ✔ - ✔ - - - ✔

PLOT3D - -   -   - ✔ - - - -

CGNS ✔ - ✔ - ✔ - ✔ - - ✔ ✔
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体積要素の種類

表5.10 構造解析

体積要素の種類

四面体 プリズム ピラミッ
ド

六面体

ファイルの種
類

4節
点

8節
点

6節
点

15
節
点

5節
点

8節
点

8節
点

20
節
点

27
節
点

ハ
イ
ブ
リッ
ド

任
意
多
面
体

NASTRAN
Bulk Date

✔   ✔   ✔   ✔   - ✔ -

ABAQUS Input ✔ ✔ ✔ ✔ ✔   ✔ ✔ - ✔ -

ANSYS Input ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ - ✔ -

Marc Input ✔ ✔   - - - - - - - -

LS-DYNA
Input

✔ - ✔ - ✔ - ✔ - - ✔ -

ADVENTURE
Mesh

✔ ✔ - - - - ✔ ✔ - ✔ -
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体積要素の種類

表5.11 プリポスト

体積要素の種類

四面体 プリズム ピラミッ
ド

六面体

ファイルの種
類

4節
点

8節
点

6節
点

15
節
点

5節
点

8節
点

8節
点

20
節
点

27
節
点

ハ
イ
ブ
リッ
ド

任
意
多
面
体

Tecplot ✔ - ✔ - ✔ - ✔ - - ✔ ✔

EnSight Gold - -   -   - ✔ - - ✔ ✔

FieldView
Unstructued

✔ - ✔ - ✔ - ✔ - - ✔ ✔

I-deas
Universal

✔ - ✔ - - - ✔ - - ✔ -

AVS
Unstructured

✔ - ✔ - ✔ - ✔ - - ✔ -

Visualization
Toolkit Input

✔ - ✔ - ✔ - ✔ - - ✔ -

Gambit
Neutral

✔ - ✔ - ✔ - ✔ - - ✔ -

Gmsh ✔ - ✔ - ✔ - ✔ - ✔ - -

Medit Mesh ✔ - - -   - ✔ - - ✔ -
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体積要素の種類

表5.12 ポリゴンモデル

体積要素の種類

四面体 プリズム ピラミッ
ド

六面体

ファイルの種
類

4節
点

8節
点

6節
点

15
節
点

5節
点

8節
点

8節
点

20
節
点

27
節
点

ハ
イ
ブ
リッ
ド

任
意
多
面
体

STL - - - - - - - - - - -

3ds Max - - - - - - - - - - -

Wavefront
OBJ

- - - - - - - - - - -

GNU
Triangulated
Surface

- - - - - - - - - - -

Stanford
Polygon

- - - - - - - - - - -

Object File
Format

- - - - - - - - - - -

AutoCAD 3D
Face

- - - - - - - - - - -
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面要素の種類

5.4. 面要素の種類

表5.13 流体解析

体積要素の種類

三角形 四角形

ファイルの種類

3節点 6節点 4節点 8節点

ハイブ
リッド

任意多
面体

Flient Mesh/Case ✔ - ✔ - ✔ ✔

STAR-CD V4 ✔ - ✔ - ✔ -

CFX Grid ✔ - ✔ - ✔ -

CRUNCH CFD Mesh ✔ - ✔ - ✔ -

OpenFOAM PolyMesh ✔ - ✔ - ✔ ✔

SU2 Mesh ✔ - ✔ - ✔ -

FaSTAR Grid ✔ - ✔ - ✔ -

LS-FLOW Grid ✔ - ✔ - ✔ ✔

PLOT3D - - - - - -

CGNS ✔ - ✔ - ✔ ✔
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面要素の種類

表5.14 構造解析

体積要素の種類

三角形 四角形

ファイルの種類

3節点 6節点 4節点 8節点

ハイブ
リッド

任意多
面体

NASTRAN Bulk Date ✔   ✔   ✔ -

ABAQUS Input ✔ ✔ ✔ ✔ ✔ -

ANSYS Input ✔ ✔ ✔ ✔ ✔ -

Marc Input - - - - - -

LS-DYNA Input ✔ - ✔ - ✔ -

ADVENTURE Mesh ✔ ✔ ✔ ✔ ✔ -
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面要素の種類

表5.15 プリポスト

体積要素の種類

三角形 四角形

ファイルの種類

3節点 6節点 4節点 8節点

ハイブ
リッド

任意多
面体

Tecplot ✔ - ✔ - ✔ ✔

EnSight Gold - - ✔ - ✔ ✔

FieldView Unstructued ✔ - ✔ - ✔ ✔

I-deas Universal ✔ - ✔ - ✔ -

AVS Unstructured ✔ - ✔ - ✔ -

Visualization Toolkit
Input

✔ - ✔ - ✔ -

Gambit Neutral ✔ - ✔ - ✔ -

Gmsh ✔ - ✔ ✔ ✔ -

Medit Mesh ✔ - ✔ - ✔ -
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面要素の種類

表5.16 ポリゴンモデル

体積要素の種類

三角形 四角形

ファイルの種類

3節点 6節点 4節点 8節点

ハイブ
リッド

任意多
面体

STL ✔ - - - - -

3ds Max ✔ - - - - -

Wavefront OBJ ✔ - ✔ - ✔ -

GNU Triangulated
Surface

✔ - - - - -

Stanford Polygon ✔ - ✔ - ✔ -

Object File Format ✔ - ✔ - ✔ -

AutoCAD 3D Face ✔ - ✔ - ✔ -
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ゾーンの識別

5.5. ゾーンの識別

表5.17 流体解析

ゾーンの識別

表面 体積

ファイルの種類

名前 識別番
号

種類 名前 識別番
号

種類

Flient Mesh/Case ✔ ✔ ✔ ✔ ✔ ✔

STAR-CD V4 ✔   ✔ ✔   ✔

CFX Grid ✔ - - ✔ - -

CRUNCH CFD Mesh   - - ✔ - -

OpenFOAM PolyMesh ✔ - - ✔ - ✔

SU2 Mesh ✔ - - - - -

FaSTAR Grid - ✔ - - - -

LS-FLOW Grid - - - - - -

PLOT3D - - - - - -

CGNS ✔ - - ✔ - -
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ゾーンの識別

表5.18 構造解析

ゾーンの識別

表面 体積

ファイルの種類

名前 識別番
号

種類 名前 識別番
号

種類

NASTRAN Bulk Date ✔ ✔ - ✔ ✔ -

ABAQUS Input ✔ - - - ✔ -

ANSYS Input ✔ - - - - -

Marc Input - - - - - -

LS-DYNA Input - ✔ - - ✔ -

ADVENTURE Mesh - - - - - -
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ゾーンの識別

表5.19 プリポスト

ゾーンの識別

表面 体積

ファイルの種類

名前 識別番
号

種類 名前 識別番
号

種類

Tecplot ✔ - - ✔- - -

EnSight Gold ✔ - - ✔ - -

FieldView Unstructued ✔ - - - - -

I-deas Universal ✔ ✔ - ✔ ✔ -

AVS Unstructured - ✔ - - ✔ -

Visualization Toolkit
Input

- - - - - -

Gambit Neutral ✔ ✔ - ✔ ✔ -

Gmsh ✔ ✔ - ✔ ✔ -

Medit Mesh - - - - - -
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ゾーンの識別

表5.20 ポリゴンモデル

ゾーンの識別

表面 体積

ファイルの種類

名前 識別番
号

種類 名前 識別番
号

種類

STL ✔ - - - - -

3ds Max ✔ - - - - -

Wavefront OBJ - - - - - -

GNU Triangulated
Surface

- - - - - -

Stanford Polygon - - - - - -

Object File Format - - - - - -

AutoCAD 3D Face ✔ - - - - -
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